BYOND Version:479
Operating System:Windows 7 Home Premium 64-bit
Web Browser:Firefox 3.6.12
Applies to:Dream Seeker
Status: Deferred

This issue may be low priority or very difficult to fix, and has been put on the back burner for the time being.
Descriptive Problem Summary:
When including # in the dmb file name, mozilla opens a new tab and asks how to run byond. Options and Messages opens, but does not load past the options and messages.

Numbered Steps to Reproduce Problem:
1 Create a new project with # in the name
2 Try to run game from dream maker or by clicking the dmb.

Expected Results:
Run normally.

Actual Results:
Trying to open in browser, then hanging on dream seeker opening.

Does the problem occur:
Every time? Or how often?
In other games?
In other user accounts?
Haven't Tried, but just reinsalled operating system, byond is really the only program on this other than the default programs.
On other computers?
Haven't Tried
When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

Don't use a #.
Since # is used for parsing server parameters (eg, ##guest), it's not a valid character for the dmb file. I suppose we could try to detect this but it's not really worth the effort IMO.