Keywords: casual_quest
Last night I updated Casual Quest with a new scoring system. Testing with a larger group has revealed a bug in the scoring system whereby newer scores can replace older, but larger, scores. This update changes the hub password, so make sure you update your servers.

There is also a fix to the Rogue's bomb arrow skill, and a bug that was causing the arrow keys to start a game in hard mode.

Programmer's note: To be honest, I have no clue how the bug started, as I didn't change that code between updates, and I was able to track it down to this line (with diagnostic output added during bug tracking):

if(which == SHIFT_PRIMARY){
world << "[which] == [SHIFT_PRIMARY]"

The odd part? That diagnostic line output the following: "4 == 512". ???? I have no clue how to fix that, so I simply replaced it with a test "which in list(SHIFT_PRIMARY)", which worked. Very weird.
lol that is odd. is SHIFT_PRIMARY a list or a string?
SHIFT_PRIMARY, as you can see from the output string, is the number "512", which is certainly not equal to 4.
That's weird, I get:
which = 528

I couldn't figure out how to bug it.
Although, I ran into a weird but that lagged the keystrokes making it so they all happened at once about 5 seconds after they were pressed. I couldn't reproduce it though.