BYOND Version:479
Operating System:Windows XP Home
Web Browser:Firefox 3.6.13
Applies to:Dream Seeker
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:
icons that are larger than 32 x 32 pixels show beyond see_in_dark sight and sometimes when they should show dont show.

Numbered Steps to Reproduce Problem:
just create a icon bigger than 32 x 32 pixels and assign it to a turf, set lum to all areas to 0 and set your see_in_dark to 3 or 2, in game, the turfs with icons bigger than 32 x 32 dissapear and appear when they should/should not be.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
icons should appear when the usr can see it, icons should not appear when they can see it.

Actual Results:
icons appear when not in sight of usr, icons dissapear when in sight of usr.

Does the problem occur:
Every time? Or how often?

every time when the area lum is set to 0. has no effect when there is lum and its not dark.

In other games?
not sure

In other user accounts?
not sure

On other computers?
i only have xp.

When does the problem NOT occur?
it wont occur if the area around you lum are set to 1, but if there set to 0 and your see_in_dark is set to 1 or higher than problems occur.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? yes, but i figured someone would probly report it.

as you can see.
I don't fully understand this report. In particular I don't get this part:

Expected results:
icons should appear when the usr can see it, icons should not appear when they can see it.

That's contradictory so I'm not sure which one you meant.

What I can tell you is that icons larger than the base size will be visible in their entirety if any part of them is on a visible tile. If that's the whole of the problem then there isn't an issue. If not, I think I'll need a demo and some clarification of the report to understand this better.
Moved to Unverified for lack of followup. A test case is probably needed to confirm anything wrong, but it's not clear this is even a bug at all.