BYOND Version:N/A (Website Bug)
Operating System:Windows 7 Ultimate 64-bit
Web Browser:Firefox 3.6.13
Applies to:Website
Status: Resolved (web)

This issue has been resolved.
Descriptive Problem Summary:
If you make a blog post and quickly discover a typo or error you didn't originally catch in preview (if you previewed it...) attempting to quickly edit the post will result in BYOND displaying the following error: Error: slow down! You must wait before posting again to this site.

Since editing a post doesn't actually count as "posting again", I consider this a bug, or at the very least, much undesired functionality.

Numbered Steps to Reproduce Problem:
  1. Write a blog post
  2. Quickly edit the post

Expected Results:
The post edit to go through immediately.

Actual Results:
The post edit fails due to anti-spam mechanisms.

Does the problem occur:
Every time: Yes.
In other user accounts: Yes.
On other computers: Yes.

When does the problem NOT occur?
After the period of time before each post has elapsed.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked?)
Yes. Site version before this one.

Deleting and reposting.
Triple checking your posts before making them (probably the most advised.)
I have a fix for this which can go in on the next update, but based on what I'm seeing this is not in fact a new bug; the issue has always been present right along.
That's certainly unexpected. I don't recall ever having this issue. Then again, I haven't blogged at a quick pace for quite some time.

And now it's happening to comments. I posted a comment on my own blog, and when I tried to post one here, I got the same error message above. I haven't had anything to do with the feature tracker this morning.