fcopy() and savefiles had trouble handling the new DDMI icon format used for client-side processing.
BYOND Version:484
Operating System:Windows 7 Home Premium 64-bit
Web Browser:Chrome 11.0.696.71
Applies to:Dream Seeker
Status: Resolved (485)

This issue has been resolved.
Descriptive Problem Summary:
When saving an icon that has had icon operations performed on it, it doesn't seem to work at all when saved via ftp() or fcopy().

Numbered Steps to Reproduce Problem:
Using this demo, it does several things.

Compile and run it.

1. Use the npc verb. It will create an obj that has its colour randomized. In the New() operation for /obj/npc, it fcopies a straight up version of I, as wells an a version with fcopy_rsc() applied. The icons it fcopies however are just useless 1 KB files.

2. Use the get_icon verb on one of the npcs. It will give you an icon that can be opened and seems normal.

3. Use the my_icon verb and select the icon you just obtained with ftp(). It doesn't even acknowledge you selected the icon.

Code Snippet (if applicable) to Reproduce Problem:
n/a: demo provided

Expected Results:
fcopy() produces usable icons, ftp()'d icons actually can be used.

Actual Results:
Lots of broken things.

Does the problem occur:
Every time? Or how often? Every time.
In other games? Untested.
In other user accounts? Untested.
On other computers? Untested.

When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? It worked fine pre-483.

Downgrade I guess.
I've been experiencing the same problem...
From what I'm seeing here, the only real issue is that you're using fcopy() to make a copy of the icon on the server side. I can see what I can do about that to force it to translate.