BYOND Version:485
Operating System:Windows 7 Ultimate 64-bit
Web Browser:Internet Explorer 9.0
Applies to:BYOND Hub
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:My game is showing up on the hub even though in dream daemon shows it can't be contacted/connected to & in fact after people trying they really can't.

Numbered Steps to Reproduce Problem:
I don't specifically know how to reproduce the bug but my guess is just host & POSSIBLY login into the game, maybe not just you though because my brother joined using the internal ip address of me on the network instead of internet ip address, this allowed him to join, this may have also thrown it off thinking people can join maybe thinking it was a false reading, but in fact nobody could technically join the game but people within my own network(LAN) & only when using the LAN ip address.

Code Snippet (if applicable) to Reproduce Problem:
Not Applicable

Expected Results:Whether it's completely bugged or it assumed people could join cause someone else was in the game at one point, it should be coded smart enough to realize someone else maybe able to join via LAN & it still not show up, if it's completely bugged anyways it needs fixed regardless.

Actual Results:Game shows on hub.

Does the problem occur:
Every time? Or how often?Every Time
In other games?Not Applicable(happens on all games hosted that have a hub)
In other user accounts?Yes
On other computers?Yes

When does the problem NOT occur?It may not happen when someone in your own LAN doesn't join the game with you to play.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
Not tested.

Workarounds:None to fix it, maybe not host it as public or not have bro join while hosting may work but I didn't think it would show up on hub, but when i went to website my own game was showing up after we finished are game together.

ADDITIONAL INFORMATION: If I didn't say this, dream daemon shows when i start the server that it's not able to be reached & nobody else who has tried to connect to the game server can even get into it.
Hub entry address required. Again.
sorry my comp randomly turned off or maybe ud of been able to see what game i was in & do it, I will re-produce the bug & give you the instructions & hub entry/game join link so you can confirm it as being un-joinable for yourself.
OK the game is up on this hub & it started to show up after i logged into my own account & to the game, logged off the pager & joined & then checked & it didnt show but when i logged in as guest, joined, and checked again, now it's showing.

I don't know the specific problem I can test more if needed but it seems more than my own key joining or multiple people joining is mistaking the game for actually being live.

Plus I don't understand why my name isn't in the online list, shows 2 people playing the game & 1 shown as private but the 2nd name, my own, is just missing, is it broken because i logged off pager & is this apparentally intended to not even show up as private if logged off, just seems odd & broken in my opinion.

EDIT:Note: When I say I logged in, logged off, joined as guest, etc... i left myself logged into the game(the game window open), clicked logoff in the pager & then joined (left that window open as well while I brought down the list of people to login as & chose guest then logged in at that point) after doing those steps exactly the game started showing up on hub even though it stayed in-accessible the whole time & is still in-accessible.

Plus the hub seems to stay indefinitely after this(until the game goes down at-least & doesn't matter who logs in or off even if everyone does)
This is the unjoinable server byond:// & the hub listed previously, I am going to create another server (joinable on the same hub so if you read this at that time dont worry its intentional & 2 different hostings of the same game, a different port that people can join with is what ill be using on the other one.)
Although I've seen this in action, I have yet to reproduce this reliably so it goes in the Unverified pile for now.
I'm still getting this to happen on a consistent basis on BYOND version 493.1117 by following these steps:

1) Open dream daemon.
2) Enter a bogus port number. (One that shouldn't be able to be connected to.)
3) Click the green GO button.
4) Join your server using the yellow Join the world with dream seeker button.
5) Exit out of dream seeker. (Leaving dream deamon running.)
6) Go the to hub page of the game that your hosting.
7) Notice your server is online with 0 players.

Step #4 is important, or else the bug will not display itself.

That being said, I tested it with previous BYOND versions and this bug begins appearing in BYOND version 471.1076 +.