ID:115836
 
Not a bug
BYOND Version:488
Operating System:Linux
Web Browser:Firefox 5.0
Applies to:Dream Daemon
Status: Not a bug

This is not a bug. It may be an incorrect use of syntax or a limitation in the software. For further discussion on the matter, please consult the BYOND Developer forums.
Descriptive Problem Summary:Either DM or DD corrupts the rsc files so you can't host.

Numbered Steps to Reproduce Problem: Compile a game, and attempt to host using DD 486-488 on Debian Squeeze x64. It will report a bug in the shell prompt about corrupt rsc.

Expected Results: The game should host properly.

Actual Results: A corrupted rsc bug prevents the game from hosting properly.
Does the problem occur:
The issue occurs everytime.
This has been tested using two branches of SS13 code.
On other computers? Our SS13 (Space Station 13) hosting files were compiled on four different Intel Windows machines using 487, and 488.

When does the problem NOT occur? When using 479.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? The latest version I know works is 479. I can confirm 486-488 don't work.

Workarounds:Use 479 to host.

The .rsc definitely should not be corrupting, so something is very wrong there. It would help to get a copy of the before and after .rsc files to see what happened. In the meantime I would also recommend you test on versions 480-482 to see if the problem existed there.

You can email me the files in question at LummoxJR@aol.com.
To clarify, are you saying you are hosting games compiled in 487/488 _windows_ DM? And can 488 Linux successfully host games compiled in older builds (eg, a 479 build)? If so, it sounds like the issue is with DD.

We do have access to a 64 bit debian so we'll do some testing.
Ok, we tested a resource-heavy game compiled in 487 windows on a 488 Debian64 server. It worked fine, so this must be something else. Please provide the exact details of what you're doing (including where you are compiling, where you are hosting, which combinations you've tested, and anything else you can think of). If you can provide us the hosting file that are failing (in linux only, right?) we can test those too. If we can't reproduce that, we'll probably need remote access to your machine to try to debug.
I tested 488 again. I'm currently hosting on 488 now without any issue. I don't believe there is a bug now. I believe that the chmod for the hosting file folder was incorrectly set so the rsc file wasn't accessible, and it spit out a BUG: rsc corrupt message. Sorry for the misreport. Good work on being so proactive. Thanks.
Thanks for following up with us. Glad to know everything has worked out. We have closed the report.