BYOND Version:487
Operating System:Windows ME
Web Browser:Firefox 6.0 (Shouldn't matter)
Applies to:Dream Maker
Status: Deferred

This issue may be low priority or very difficult to fix, and has been put on the back burner for the time being.
Descriptive Problem Summary:

When I open Dream Maker on my other Windows ME computer, it starts up fine and I choose to open an environment, then click on an icon and edit it by click on the paintbrush, as soon as I click on the back arrow or the Plus or Minus signs to zoom in on the icon while editing, Dream Maker stops responding and freezes

Numbered Steps to Reproduce Problem:

Open Dream Makers, Open Environment, Open icon.dmi file, click on the Paint/Canvas picture, then click the Back Arrow or the little Plus and Minus signs to zoom in on the icon.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

I expect Dream Maker to take me back to the screen with my previously made icons, and to Zoom in or out when I click the Plus and Minus buttons.

Actual Results:

Dream Maker just does nothing at all, no pop up or anything. It just freezes.

Does the problem occur:
Every time? Or how often?

In other games?
Haven't tried it on games yet, but I assume that would be fine.
In other user accounts?
On other computers?

My 'old' other one?

When does the problem NOT occur?

Never or when I don't try to edit icons in Dream Maker.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

Byond Public version: 487

This has been happening ever since the Zoom feature in Dream Maker's art editor has been implemented. Byond works fine on my Windows 7, but it won't work on my Windows ME.

I'll see if I can figure something out here. I can't make promises because at this point 98/ME support is more accidental than anything else, since both are way outdated and pretty much everyone is using XP or higher nowadays (and also ME notoriously sucks).

I will mention that your browser isn't totally irrelevant. Firefox has been having bad, bad memory problems since at least 4.0, and moderate memory problems well before that. Those issues won't be fixed until at least 7.0, so it is possible that your browser is eating up your system's memory at a ferocious rate and your 16-bit OS just can't take it with DM running as well.
I completely understand. Windows ME is Way outdated and not the best, plus Windows ME was released 10+ years ago so it isn't really your top priority xD. So I can clearly see where your coming from.

-Thanks for reading