BYOND Version:490
Operating System:Windows 7 Home Premium 64-bit
Web Browser:Firefox 6.0.2
Applies to:Dream Maker
Status: Resolved (490.1112)

This issue has been resolved.
Descriptive Problem Summary:
"I bat man was patroling the streets of Byond-them, When King Lucifer Robin spoted something amock! We then got in the Pwnmobile"
Setting bounds to non-tile multiples (ie: 33-63), will cause lag when moving.

Numbered Steps to Reproduce Problem:
Download demo
Run demo
Move a single tile, notice "gliding"
Uncomment the noted line(s) in the source
Run demo again
Move a single tile, notice "jump"
This video demonstrates how bad the problem can become (video by King Lucifer)

Code Snippet (if applicable) to Reproduce Problem:
See demo

Expected Results:
Bounds on objects don't have a negative effect on movement systems

Actual Results:
Certain bounds make movement laggy

Does the problem occur:
Every time? Or how often? Every
In other games? Yes
In other user accounts? Yes
On other computers? Yes

When does the problem NOT occur?
If you use bounds in multiples of 32, or presumably whatever icon_size is set to (didn't actually test against icon_size).

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

None that would provide the desired results?
I've tested your demo and also encountered the same bug.
Fix: Key repeats were subject to some timing issues that were made more apparent when gliding was disabled and normal 10 fps speed was used.
Why is gliding being disabled by setting bounds?
If a project uses pixel movement, gliding is meaningless.
It is using pixel movement, because the odd bounds mean that bumping the object will cause a partial move and impart a step offset to your mob. If you want density on a full-tile basis only, use full-tile bounds.