Descriptive Problem Summary:
I downloaded byond on linux mint 11 lxde using WINE, i then after messing around getting it to work now have the problem of 'cannot read key file' and have tried deleting the key file and restarting byond pager, i have tried changing the directory and still no luck any help ?

Numbered Steps to Reproduce Problem: byond 490
2. install using wine
3. use the byond pager

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
able to play byond games

Actual Results:
cannot read key file

Does the problem occur:
Every time? Or how often?
every time

In other games?
cannot try because i can't get that far

In other user accounts?yes
On other computers?N/A

When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)


Either the key.txt file in BYOND's data directory is messed up, in which case you can just delete it, or there is a permissions problem with the data directory.
i done that already
I have had the same problem in byond 493.1117 running on wine 1.4_rc1 on a 2.6.27-gentoo machine. I have tried each of reinstalling byond, removing the 'key.txt' file, and restoring the key.txt with its original (non-empty contents). In each case the key.txt file gets replaced by an empty file (and created if it does not already exist), and I receive the "Cannot read key file!" error. Any suggestions?
I recall having this problem; also on an up-to-date gentoo machine. If I am remembering correctly, it was a permissions problem to do with WINE and BYOND writing data to the directory, as Lummox suggested earlier.

I seem to recall that I got it working through the highly unethical practice of just running it as root; I know there's a better way to do it than that, but I'm afraid I can't tell you what it is, myself.
Hmmm. I've got a similar problem; I have tried:

- Running as root. Did not help.
- Giving the key.txt file read, write, and execute permissions. Did not help.
- Together with the previous, giving the BYOND directory read, write and execute permissions. Did not help.
- Logging in as Guest. It verified the key file, but failed to log in (wine gave the following output:
wine: Unhandled page fault on read access to 0x00000000 at address 0x100660b2 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x100660b2).
...and then several pages more)
- Removing write permissions from key.txt. This failed to work, but did not reduce the file to a zero-length file. (Note that permissions to delete the file were in place).

From that last test, I've deduced that the file is not being deleted and replaced - rather, its contents are being replaced with nothing. I do not know why this should be the case.
...never mind, updating wine to the latest stable version fixed this.
I'm getting this error on WineSkin for Mac. Chmod 777 doesn't fix it. Updating to the latest wine doesn't fix it. This is in the wine log:

fixme:ieframe:PersistMemory_Load (0x1609d0)->(0x10164f74 9c)
fixme:ieframe:OleControl_FreezeEvents (0x1609d0)->(1)
fixme:ieframe:OleControl_FreezeEvents (0x1609d0)->(0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
fixme:msvcrt:MSVCRT__sopen_s : pmode 0x1920a8 ignored
fixme:msvcrt:MSVCRT__sopen_s : pmode 0x1920a8 ignored

I'm using wrapper: Wineskin 2.5.5
I'm using engine: WS9Wine1.5.2
Winetricks: ogg mfc42

Do I need to use a different wine than WineSkin?
Frogger, that doesn't appear to be related to the issue in this thread. I recommend starting a new thread.
Actually, it seems very related. The line

fixme:msvcrt:MSVCRT__sopen_s : pmode 0x1920a8 ignored

appears the moment the login button is pressed, so that must be where the problem lies. I have tried winetricks msvcrt, but there is no such thing.

Sorry for the necrobump, but it would still be nice if this could be resolved.
BYOND isn't officially compatible with WINE Which you can see here - objectManager.php?sClass=version&iId=10152

More than likely a wine issue..