None relivent

Problem description:

One icon (64x64) in my game decided to act very oddly earlier.

Believe me when i say, all i did was add a couple of frames to an icon, change the delay/and set it to repeat. That was it. But this is when the trouble started.....

The icon displayed the wrong icon_state on the map, yet showed the correct icon_state in the map editor (at the side in the obj & turf tree) before it was placed.

Compiling and going into the game... the animation flicked between all icon states in the icon file! and when checking the icon_state of the object to make sure it was the correct one, it was! Yet it showed something totally opposite.

After removing all icons from the file in question (leaving only one possible state), it continued to show one distorted version of icon that was not even in the files anymore.....

I tried a Clean Compile of course, removing all icons and such in my BYOND CACHE folder..... nothing seemed to solve it.

Much deleting and removing of the same icon file later, and it seems to have gone away..... for now. I have no explination for this. I'm concerned if this suddenly shows up in other icons files, as i really did nothing to solve it, it just sort of fixed itself.

I'm not sure where to post this, as i have nothing to give BYOND to "replicate" this issue. But thought id mention it here, incase someone else had got this issue too. I have never had an issue like this before ever, but then ive only been using v470 of BYOND for the past two days so....
What BYOND build did you run it with? If it's anything under 470.1075, you should upgrade and try again.

Otherwise, try leaving that icon_state nameless in the icon file, while the other icons have names. This proved some success in a scenario where I had a similar problem to yours.
In response to Cloud 10
Yeah im running v470.1075.

I just encountered it again. By doing the same thing, added a few frames to the icon animation, set a delay. Now the icon_states seem to be reversed.

Reversed as in, the three turfs within the group, two have have their icon_states switched.... and same problems as before. The icon seems to be randomly flicking between all states......

This isnt anything special, im simply defining a turf and pointing it to an icon :S no clue why this issue should suddenly spring up.


I have deleted the icon file, remade it. I have changed the turf name, tried a different icon file name. Same results. As soon as i seem to edit this icon file (64x64), it displays this strange behaviour. I must admit im not aware of any other icon files in my game that use 64x64 pixel icons.... so maybe its limited to this particular size for some reason (i hope anyway, if this starts happening to other icon files im stuffed..).


Something even more odd. When in the game, i cannot edit the variables of the turf..... not the ones that are being displaying incorrectly anyway. Im using an old GM library, which give u the ability to view an objects/turfs variables. I can edit the variables of any turf/object in the game... however when i view these (it shows them in the HTML window) and click the links to bring up the input box to change them, nothing happens.....
This is an issue that was fixed for build 471. Once that is released you won't have to worry about this anymore.
In response to Lummox JR
Ah good because ive just discovered i cannot edit ANY icon in my game without them going bonkers! >.<

It had me quite worried indeed to say the least. So this is def a known issue then? And also is it something thats going to require me to go back to previous versions before the game was unaffected?