Okay, i'm simply trying to make my map size equal that of my view size. Why? 32x32 icon view is much prettier then the stretched view... especially in the isometric view. Every time I attempt this however, they never match even if the map is not resized/stretched when the window is maximized.

I'd rather not make the map bigger then the view -just- to keep the 'aspect ratio'.

Halp! ;-;

Screenshot of Issue:

Uncheck that in the very light blue.
and make sure you have the stuff set right in yellow.
In response to Leur
Everything is exact, problem still exists.
In response to Stevenw9
Hmm, since you are using isometric map, are you counting left right? If so thats wrong. isometric map is basically turning a normal map so you would have to count diagonally just as if the normal map was turned. (I'm not 100% on this however)
In response to Leur
If you can give me a set of numbers that works, i'd be happy to try them. o.O
You can prevent the map from being set to stretch-to-view icon size by explicitly setting its icon-size parameter to something different yourself (the value of stretch-to-view is 0), using winset(). For example:
return ..()

This sets the map icon size of every player to the world's tile size (note that this will probably only work when world.icon_size is set to a number), so icons are seen in their natural size.