In my project dmb2exe, whenever I run said project from the pager ( My Hub -> Demos -> dmb2exe( Something weird is going on there too because I released dmb2exe as a game. ) ), it fails to run a specific shell() command( shell( "makensis setup.nsi" ) ), as in that the prompt for a permission( "Do you want to allow blah blah to execute?" ) doesn't even come up.

But when I navigate to the folder which the project was downloaded to by the pager( ie. docs/byond/myhub/metamorphman/dmb2exe ) and run dmb2exe.dmb from there, the shell() command is able to run perfectly.

Is this because of something I'm overlooking or some sort of security restriction the pager imposes on games/demos/libraries ran from there?
Sorry, I'm still having trouble with this.
I think it's somewhat related to bug tracker issue 554 ( BYONDHelp?command=view_tracker_issue&tracker_issue=554).

Also, in a test project folder I created test.bat. If I do a shell("test.bat") everything runs and works fine. If I do shell("test") it doesn't work at all. However if I run shell("calc"), it works without needing to specify .exe at the end, so my working theory that you needed something like makensis.exe fails. :(
In response to Skyspark
Sorry, but could we get any update on this? It's a very annoying problem.