Okay, okay I know this sounds like a noob question but it ain't. I'm not sure if this is a bug in the BYOND Software so I didn't report it at such.

Problem: When I click Build >> Run nothing happens, I will then click Ctrl+Alt+Del and go to processes(I think) and dreamseeker.exe will be on there just because I tried to run the game, however it never shows up on my screen.

This has been happening to all of my games and I do not know of a way to fix it, I've had about 4 sources do this to me and I've had to discontinue every single one and I'm tired of it. If you have any knowledge about this or any suggestions on how to fix it please reply.

Thing's I've tried using to fix it:

Copy and Pasting the source.

Making a New Environment and Copy and Pasting code and then importing the icon's.

Remaking the code by hand and icons by hand(This worked however I'm not willing to remake a thousand icons)

System Restore

Reinstalling BYOND and Dreamseeker and Dreammaker

Nothing works...
That happens most likely because you have an infinite loop (or two or more), that have no delays in them.
In response to Spunky_Girl
Sounds about right I do have a few infinite loops however they do have sleep() in them
In response to SadoSoldier
It works, thank you.