I have found nothing so far that has helped. I think it just might be because of an ad.
I'm using Chrome and I have same problem
Dunno if this helps, but windows 10 got a "Security update for flash player for internet explorer" today. Maybe that is the cause?

For further clarification: I have this update, the problem started after I got it.
The game started working fine for me earlier in the day. Just at one point it froze and I tried to join the server again. That's when it started saying that dream seeker was not working. I didn't have anything installed or updated.
I forgot my laptop updates automatically when it's off. So when I uninstalled

Security Update for Internet Explorer Flash Player for Windows 10 Version 1511 for x64-based Systems (KB3132372)

it started working again.
In response to PlayerTwo542
Yep, that's the one. I made a sticky post for this problem since it affects so many people. Skype is having issues too, so no doubt before too long Microsoft will release a new patch that isn't frickin' broken.

If anyone would like to hasten the day I can become a supervillain and nuke Redmond, please tip generously.
Yup, sorted now. Thanks guys.
So basically you have to uninstall the Flash Player and it will work?
In response to SPMG
No, you have to remove the security update that caused this.
I do not have that update though. This is strange, there is already a fix for Windows 10, but not for Windows 7? I really hope it will be fixed soon.
I had this problem and it was awful, I tried everything. I restarted my computer, deleted byond and cleared out my recycling bin, than tried reinstalling byond. Nothing worked.

TheLlew wrote:
For those that have Windows 10 and are using Edge..Do a search on the bottom left of your desktop for Internet Explorer, its hidden in 10. Once Internet Explorer is open, right click in an open space at the top of the browser and click on Menu Bar. this should show File, Edit, View, Favorites, Tools, and Help underneath the search bar. Click on Tools, and find ActiveX Filtering, click on that and it should be checked. go back into BYOND and try to join a game.

However this indeed worked, and I thank you for it.
In response to SPMG
Are you having a crash, or is it just getting stuck?
Just ran into this problem but found this thread I hope this works.
Update removed the Security Update (KB3132372) and it opened imediately. Byond is fixed now thanks guys.
I use windows 7 in IE 11 find ActiveX Filtering, but it dont help me, after running byond and try connect to server byond just freeze, and 3 dreamseeker process stay in Task Manager, and 2 out of 3 process cant close, only restart pc help. This happend after i download new byond version. I dont download any microsoft update. So pls help me.
In response to Scerob
You're having the Avast issue. Add the BYOND installation folder to your exceptions and report the false positive to Avast.
control panel, internet options, security, for all 4 zones (internet, intranet, trusted, restricted) go to custom level, and enable activex filtering.
Thanks @Llew.
Thanks. I had this exact same problem, but the ActiveX filter option in Internet Explorer fixed it for me. Cheers!
Page: 1 2 3 4