Actually this gave me total WTF moment today^^

after downloading the server files per ssh on my server (Ubuntu 10.04 LTS)( and following the steps in the readme for a system wide installation i ran into some trouble actually running the binarys.

amsel@server:~/$ DreamDaemon
-bash: /usr/local/bin/DreamDaemon: No such file or directory

So i set it up for personal use, because i thought something was wrong with the path variables, and tried to start the executables diectly from the byond/bin/ directory which left me totally stunned:

amsel@server:~$ cd private/byond/bin/
amsel@server:~/private/byond/bin$ ls -la
total 6128
drwxrwxr-x 2 amsel ****** 4096 Jan 30 19:22 .
drwxrwxr-x 8 amsel ****** 4096 Jan 30 19:41 ..
-rwxrwxr-x 1 amsel ****** 21704 Oct 5 01:45 DreamDaemon
-rwxrwxr-x 1 amsel ****** 13044 Oct 5 01:45 DreamDownload
-rwxrwxr-x 1 amsel ****** 16488 Oct 5 01:45 DreamMaker
-rwxr-xr-x 1 amsel ****** 706 Jan 30 19:22 byondsetup
-rwxrwxr-x 1 amsel ****** 4124648 Oct 5 01:45
-rwxrwxr-x 1 amsel ****** 2065984 Oct 5 01:45
amsel@server:~/private/byond/bin$ ./DreamDaemon -version
-bash: ./DreamDaemon: No such file or directory

As you can see from the file list and the file permissions, they should be there, but, well...

When typing, i use autocomplete, so i shouldn't have misstyped the filename, so the only thing i can imagine, is, that something is realy wrong with my shell on that server, which could be possible since it was just set up.

Anyone a idea?

Actually i was missing the 32 bit compat libraries

sudo apt-get install ia32-libs

will install them.

I found ou by checking the ELF deendencys:

amsel@server:~/private/byond/bin$ readelf -l DreamDaemon
Right, because BYOND is compiled specifically for 32-bit usage. The compatibility libraries are required to give BYOND access to come core libraries it requires. Should probably be something in the installer to account for this and install the compatibility library as a dependent.
^ +