ID:2306572
 
Resolved
Screen-edge HUD positioning caused position problems with maptext and KEEP_TOGETHER cases.
BYOND Version:512.1392
Operating System:Windows 10 Home 64-bit
Web Browser:Chrome 61.0.3163.79
Applies to:Dream Seeker
Status: Resolved (512.1393)

This issue has been resolved.
On behalf of U4M

Descriptive Problem Summary:
When applying an 'outline' filter to maptext that is positioned using LEFT/BOTTOM positioning, the maptext either disappears, or gets placed way out of position.

Numbered Steps to Reproduce Problem:
http://files.byondhome.com/Flick/ screen_loc_filter_bug_src.zip

Clicking 'test1' switches between maptext with and without the outline filter and a screen_loc of "LEFT+5%,BOTTOM+5%". With the filter, the text vanishes.

Clicking 'test2' does the same thing, but with the screen_loc set to "1,1". This works fine. The outline shows up and disappears on the maptext in correct position.

The NORTH/SOUTH/EAST/WEST positionings work fine.

Code Snippet (if applicable) to Reproduce Problem:


Expected Results:

Actual Results:

Does the problem occur:
Every time? Or how often?
In other games?
In other user accounts?
On other computers?

When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

Workarounds:

Use "WEST+5%,SOUTH+5%" instead, although that wont work in all situations.

BOTTOM and LEFT makes animations wonky too. I was using a two step animate loop and the frames seemed almost like they were playing out of order.

Edit: It also selectively blurs things behind it. Not sure of the exact reason:

without filter


with filter


The third one is always the one that doesn't blur. I'm not sure why the left side of the text has no outline either.

Edit 2: Found a workaround for the left side not getting outlined properly -- make the first character of the string a space.
Lummox JR resolved issue with message:
Screen-edge HUD positioning caused position problems with maptext and KEEP_TOGETHER cases.
Thanks a ton Lummox, you're the best! I'll try to dig a bit deeper into the blurring issue and make a new topic for you once I or someone else can come up with an isolated environment. :)
This is marked as version 512.1293 instead of 512.1393 as it should be
In response to Ninjanomnom
Thanks!

Login to reply.