ID:2322326
 
BYOND Version:N/A (Website Bug)
Operating System:Windows 10 Home 64-bit
Web Browser:Firefox 57.0
Applies to:Website
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
When trying to upload a small icon or a banner to the game hub at the 'graphic' tab. It shows it should be uploaded but the image doesnt appear. Also when i click save after it just doesnt show up. I posted this on the forum and on the byond discord and they told me this might be a bug since if you go to the banner page: http://www.byond.com/games/banners/110900.png it does show there. But not at the game hub: http://www.byond.com/games/Chaokai/RiseofHeroesUnlimited.

Numbered Steps to Reproduce Problem:
Step 1: Went to the gamehub by clicking on publish games and the clicking the game.
Step 2: Clicked the 'Graphic' tab.
Step 3: Clicked to upload the image on either small icon or banner.
Step 4: Clicked save.


Expected Results:
Normally after uploading you should see a preview of the image, this is not the case. Also after clicking save it should be posted on the gamehub, again not the case.

Actual Results:
The image is uploaded but invisable.

Does the problem occur:
Every time? Or how often?
I get the same result every time.
In other games?
Yes.
In other user accounts?
Not tested.
On other computers?
Yes.

When does the problem NOT occur?
When uploading the 'Large icon", this did work and is uploaded just fine.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)
I dont know about older versions. I used to make a gamehub like years ago and then it did work. I also downloaded the newest byond version, still same results but yeah it's a website issue.

Workarounds:
No workaround i know of.

Extra info:
Forum post: http://www.byond.com/forum/?post=2322260
Hub entry: http://www.byond.com/games/Chaokai/RiseofHeroesUnlimited

Small icon:

Size: 32x32
File size: 1.82kb
File type: PNG

Banner:

Size: 245x60
File size: 18.2kb
File type: PNG
It looks like it didn't actually save. Have you tried uploading both images again?
Okay, looking at this I can see the small icon actually did upload properly. It's not showing up on the editor page because of a problem with the page CSS and the way it interacts with the graphic. That's pretty fixable.

The banner image is there, but it's not showing up on your editor page, and the editor doesn't show an option to delete it. It looks like although it uploaded it didn't do so correctly. I'd try re-uploading the banner.
Oh okay, thank you for your response Lummox JR.

I thought it was weird. So basically you are working on it right, gotta wait then ^^
Well first you should definitely try re-uploading the banner. As far as I can tell, even though the image uploaded the system doesn't seem to recognize it. I'd like to know if that was a one-off glitch or not.
I have tried re-uploading it, also tried different images but it seems not to work still. Also i tried using different browsers (chrome, firefox, internet explorer). Still no solution.
Update:
I have been testing some more options. Using different file types: .bmp / .jpeg / .png (original)

Also using different sizes didnt have any effect on this combined with the different file types.

So far i can see this really looks like a visual bug in the CSS code prob from the website.

I hope this can be resolved.

Login to reply.