Descriptive Problem Summary:
When I try to subscribe to any game on the site, I'm given a list of options if they have any, but no actual way to subscribe after picking the option. I tried gifting it to myself and the result is the same.

I've tried my main browser Chrome and Microsoft Edge

Numbered Steps to Reproduce Problem:
Go try and subscribe to a game.

Expected Results:
Should be able to subscribe.

Actual Results:
Can see the sub options but no actual way to subscribe.

Does the problem occur:
Every time? Or how often?
Every time.
In other games?
I've tried other games same result
In other user accounts?
I've tried other accounts too.
On other computers?
Tried all the pcs in my home plus my mobile.

None atm

In the case of Plunder Gnome, Iain doesn't have a PayPal email setup for the game yet. That's why there's no option to pay.

I checked another game that I know uses subscriptions, and it didn't have a problem. What other games are you seeing this with?
Lummox JR changed status to 'Unverified'
I just looked at a couple other games I could find with subs, Azusa and Last Conflict. I deleted my cookies/cache on Chrome and its appearing for those properly now so looks like it was just an issue on my end for those 2 games
Iain has fixed the issue with Plunder Gnome, so I'll move this out to BYOND Help.
Azusa always used byond's subscription and, wellp, suddenly I have been getting some weird reports some people can't subs;
I double checked its paypal email after seeing this topic and there was nothign wrong with it o.o
In response to Inutaishos
I'm not seeing anything wrong on your subscription page.

Login to reply.