(See the best response by Mikau.)
PROBLEM: When launching any game, or just every game I've tried, the normal blue launcher comes up, and says that it's connecting. After a few seconds, it quickly says "Connection failed" and closes.

What operating system and/or browser are you using? I'm on a Vista and I use Chrome.

What were you trying to do when the problem occurred? I was trying to launch a game.

What actually happened, and how did it differ from what you expected? What actually happened is that the launcher failed and then closed. I expected each game to start and run normally.

Explanation of problem occurrence in sequences: 1) Open Pager and either use the Bookmarks function, the "Join Friends" function, or the direct connect function to connect to a game. 2) The launcher opens as normally expected. 3) The launcher then fails, either by actually flashing the "Connection failed" screen or just closing all-together. 4) I get a little upset.

Other information: What I THINK the problem is, and I'm dreading confirmation, is my ISP. I use Wildblue satellite internet because of my current living situation. It isn't too slow, but there IS a pretty wicked delay at all times (the games I'm wanting to play aren't too action heavy. I'm aware that that would be difficult). I've played BYOND on everything from Dial-Up to Satellite before, so I'm doubtful that this is the issue, though.

What I've already tried: I've tried reinstalling, I've cleared my cache, I've made sure the DNS is correct (it is). I've tried different games, I've made sure that I'm the administrator. I've restarted my computer, I've tried different keys.

I'm not the best with computers, so if you suggest something, it'd be really helpful if you used small words and detailed steps. I'll do my best to answer questions in as much detail as I can, and I'm sorry if this report wasn't detailed enough.
Best response
Your problem is most likely that your firewall is blocking dreamseeker.exe from connecting.

Try to disable windows firewall first and connect to a game, if it connects then you know it's a firewall problem.

Go into control panel and click windows firewall, from there you can turn off the firewall.

If you can connect, turn the firewall back on, then go to advanced settings, and from there you can set inbound and outbound rules for the program. There's a little wizard to help you through that part.

Alternatively, you can leave windows firewall off, and google "Avast" It's a free antivirus and firewall program that is much better than windows basic firewall.

Let me know how things go.
Haha. That worked, man. Disabling Windows Firewall entirely worked. I probably should have mentioned that I already have Avast.

Leaving the Windows Firewall off and just using Avast isn't going to hurt me in any way, is it? Computers and their magical ways scare me.
I understand. It's back up and I set up the exceptions for BYOND. You're good people.

You too, Mikau. Thanks both of you for the help. Cool points earned all around.