ID:2374014
 
BYOND Version:511
Operating System:Windows 10 Pro 64-bit
Web Browser:Chrome 66.0.3359.139
Applies to:BYONDexe
Status: Open

Issue hasn't been assigned a status value.
I've had a few outside users complain about our game failing to launch properly when using BYONDexe.

I've investigated the issue and it looks like in select cases the installer package isn't properly creating the cache directory in the Documents\BYOND\ folder. It's very quickly resolved by having them press 'Clear Cache' since this'll recreate the directory if it doesn't exist. This only happens on Windows 10 systems.

It would be nice though if new users didn't have to go about this when installing the game.
That's really odd, since creating the cache directory should always happen. This is gonna be a very hard issue to investigate, though.
As an update, this seems to be happening on about 50% of our Windows 10 users who have never installed BYOND before. Their first installation is through BYONDexe.
can confirm windows 10 cache folder issues.

users who press clear cache during normal usage have also reported it failing to create it until they restart byond.exe
This is becoming more and more of an issue. A big portion of our outside users are running into this issue and dropping the game entirely.
I haven't forgotten this, although it's still gonna be a bear to investigate.
I can confirm that this is the same issue I'm having in the thread I posted about not being able to get in a game even locally. However, I am running it from the pager, not BYONDexe
I've added some code that might take care of this in 512.1428, so please give that a test when it's out.
I've had this happen only when updating BYOND from the client.

Login to reply.