BYOND Version:511
Operating System:Windows 10 Pro 64-bit
Web Browser:Chrome 70.0.3538.102
Applies to:Dream Maker
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
So, not really sure how to fully explain it -
basically while ripping sprites, when re positioning multiple iconstates DM will randomly start turning icons blank when you edit them / add new ones.
Numbered Steps to Reproduce Problem:
Place numerous gifs and re position them, until it just..breaks.
Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
Actual Results:
Does the problem occur:
Every time? Or how often?
very random when it happens, it's just simply after a number of "states" after made.
In other games?
In other user accounts?
On other computers?
When does the problem NOT occur?
It always happens after a certain amount of states
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
Has always occurred to my knowledge

Restart Dream Maker.
You might want to try this in 512. So many things have been fixed since 511 that it's really best to get on the beta.
Just tried to get the error to occur in 512 and it still happens.
Basically I'm just constantly moving around sprites in the icon editor, that's how I replicated the issue anyway.
Ah, so this is a function of the list control the icon editor currently uses.

The bad news is that's still in place in the release that's coming today. The good news: I plan to nix that control in a future release by applying similar methods to what I just did in the pixmap editor.
Oh okay, that's awesome to hear - my workaround just became using the same icon size in photoshop and using gifs.
Mind you the icon page's list control is just suffering the symptoms worse than most. The cause is having a large number of states in the icon, which is inefficient. However I imagine you're trying to move those states into movies so you end up with fewer actual icon states and therefore a more wieldy result.
Yeah exactly, pretty annoying when I'm trying to line up a walk state and everything goes blank.