ID:2425520
 
BYOND Version:512
Operating System:Windows 10 Pro 64-bit
Web Browser:Chrome 71.0.3578.98
Applies to:Webclient
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:

When multiple mobs are on the map, the webclient cannot render their movement individually. The icons get swapped, and neither can be displayed on screen at the same time.

Numbered Steps to Reproduce Problem:

1. Launch quick demo in Dream Daemon
2. Join on web client
3. Move around.

Code Snippet (if applicable) to Reproduce Problem:

mob
icon = 'mob.dmi'
NPC
icon_state = "E"
BadThing
New()
spawn(1) ..()
AI()
proc/AI()
set background = 1
while(src)
step(src,pick(NORTH,SOUTH,EAST,WEST))
sleep(5)


mob.dmi has 2 states, one for players, and one for NPCs (named "E").

Expected Results:

Both mobs should be rendered at the same time, and show their own icons.

Actual Results:

Neither mob renders properly.

Does the problem occur:
Every time? Or how often? Every time web client is used.
In other games? Found when testing a project, replicated multiple times in other environments.
In other user accounts? Yes
On other computers? Yes

When does the problem NOT occur?

When using Dream Seeker

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

Unable to check. Unable to test prior versions of webclient.

Workarounds:
None that I have found.

Well that's frickin' weird. I wonder when/how that broke. Something I'll have to look into when I get back to webclient work.

Out of curiosity though, why can't you test prior versions?
(Sorry for this late reply, medical emergency)

At the time I was posting this, I was not able to download/use other versions of BYOND. I was on a computer not mine, and planned on testing when I was back at my own personal machine. I am able to now, and will gladly test it if you want me to. I should have the time today. I have no idea what version to start from, though, as I rarely used the webclient before this past week.
Just tested through different versions. Appears the last time it worked was version 512.1395. Everything up to and including that build seem to work as intended.
Hmmm:



Build 512.1396


Fixes (More Info)

Dream Daemon

  • The world.vars and global.vars lists did not behave like proper lists. (MrStonedOne)
  • Images with pixel offsets did not apply those offsets when determining visual bounds. (Lummox JR)
  • Setting a movable's bounds so that they overhung the edge of the map would allow movement beyond the map. (Mystery16)
  • Many hard-coded procs such as Move() did not handle arglist calls gracefully. This has been rectified for movement-related procs but still needs changing for some other built-in object procs. (FKI)

Dream Seeker

  • Prompts for missing verb arguments could cause problems with macros, especially the Any and Any+UP macros. These macros, and any macros fired when "unsticking" keys, will no longer prompt for missing arguments but will simply fail silently in those cases. (Ninjanomnom)
  • When the server told the client that turfs with visual contents were no longer needed, the client misinterpreted the message, causing visual glitches. (Tigercat2000)


Features (More Info)

Dream Daemon

  • The proc scheduler has been updated to improve response times for various cases arising in complex games. Also, a number of experimental changes have been made under the hood to improve server performance.





I wonder what change caused it...
Those changes don't line up with anything on the webclient that I can think of. Very strange.