Problem description: See this Pic.

The Black Background in the Turf. Any idea of how to fix this?

increment the layer of the bar.

layer=x//where x is a number you choose
In response to Getenks
o.o It dont worked :O!
In response to Gohan Games
Check to see if it is a turf. It could of overlapped/deleted the turf under it.

Change it to a object then


changes its layer
icon_state = ""
layer = 10 //Change this for layers (think of it as clothing) socks before shoes.
In response to Kozuma3
The grass and the Bar are Turfs. But idk why this happens, in my other Games i didnt have that problem. And that didnt worked.
In response to Gohan Games
Try changing the bar to a object.
In response to Kozuma3
That's worked. but why didnt work as turf?...
In response to Gohan Games
Most likely because when it creates a new turf or your placing down a turf it might overlap unless you press ctrl or alt. (im kinda sure)
In response to Kozuma3
Huh i find the Problem. > Options > Click Behavior > And Check Control + Click to Replace :D
In response to Gohan Games
Your Welcome.
In response to Kozuma3
Couldn't you just take an easy way, and take your grass icon, and just plop the bar onto it? There you go, fixed.

BTW, that bar looks a lot like Kamis lookout in Falacy's dbz hu game.