When running a BYOND application in Dream Seeker, my CPU will not dedicate to it more than 50% of its total processing power. I recently ran a system recovery to patch up a networking bug, and my CPU was not limited preceding this. I'm running Windows Vista (Service Pack 1) and I'd like to know how to remove this 50% limitation as I somehow did prior to the system recovery. Any suggestions?
Do you have a dual-core CPU? I'm not sure if BYOND is multithreaded. If it isn't, it's never going to break the 50% mark.
In response to Jp
Yes, I have dual core processors, but somehow I was allocating over 50% before reverting to factory settings. I just want to restore the previous settings that allowed for full CPU usage.

In further detail, I am working with BYOND worlds that run at a tick_lag value of 0.2, and I'm guessing require about five times the default processing power. Player movement, alone, is now slower, and the game itself slows down when there are several simultaneous computations being made. Another important thing to note is that I recently installed the latest version of BYOND, which I may not have had before, and perhaps prevents multiprocessing.

Is there some way of managing my CPUs (enabling, disabling, allocating maximum usage, etc)?
In response to Lethal Dragon
BYOND itself cannot use more than one cpu, has not been able to in any release.
In response to Lethal Dragon
BYOND code will use up to 50%, other extra percentages might be caused by input/message handling, or Windows flooding application to get it's reply.