ID:281263
 
(See the best response by Higoten.)
PROBLEM: I've recently joined BYOND and so far I have not been able to play a single game. I clicked on the "Play Now" button (there was no evidence of any need to download) and the little blue box that says "logging in..." popped up. The problem is it just stays there and it doesn't log in

What operating system and/or browser are you using? I'm using Vista and Chrome.

What were you trying to do when the problem occurred? Trying to start up a game.

What actually happened, and how did it differ from what you expected? It doesn't ever go past the blue box that says "logging in...", obviously I expected to log in.

Explanation of problem occurrence in sequences: (1) Chose game (2) Clicked "Play Now" (3)[PROBLEM] I fail to log in

Other information: I've tried it with multiple games and with the windows firewall off. No message comes up telling me why it never logs in. I have left the "Logging in" box for over an hour and it still doesn't log in. I'm a UK user...
Hello and welcome to BYOND!

Have you tried logging in manually?

To do this:

1) Navigate to START > All Programs > BYOND > click BYOND.exe.

2) This will open up the pager. From here type your key name(The_Wild_Card) into the Account: field, and your password into the password field.

3) Click Login

4) If you logged in successfully, you will see "Logged in as The_Wild_Card[public] in the bottom of your pager.

5) Now try to join the game you wish to join and see if you still get stuck at the Logging in... screen.

If you go to Start > All programs and don't see any BYOND folders. You may not have successfully downloaded BYOND. You can download the latest version of BYOND here: http://www.byond.com/download/
You should also reinstall the software as an administrator if you haven't done so in the first place. It might be hanging waiting for you to agree to let the program run (User Account Control), which is just not popping up for some reason.

Vista is a very weird and buggy operating system. I highly recommend if possible that you upgrade to windows 7, or downgrade to windows xp. I avoid Vista like it's the plague.
@Higoten: I tried this and it still didn't work, however it did say "BUG: Failed to open server port". Any advice for that?

@Mikau: This is my laptop, and I'm the only user so I am already admin. Also, I'll try and change my operating system at some point.

thanks so far :)
Best response
BUG: Failed to open server port is almost always caused by a misconfigurated firewall.

I see in your initial report, you mentioned that you turned windows firewall off completely. It is possible that you have other firewalls on your computer, try checking your antivirus software and other software on your computer that may have a firewall ( If you have a Nvedia graphics card, that may come with a firewall reinstalled on it).

The parts of BYOND that you should look out for when checking your firewall settings are byond.exe, dreamseeker.exe, and dreamdaemon.exe. You should disable any hash checks as well.

Good luck!
Thanks, I found a stupid MacAfee firewall that I thought I'd deleted ages ago. Thanks for the help :)