I downloaded and installed BYOND with WINE but when I try to open it it sais on the panel Starting Byond then just closes.No windows pop up or anything.

I'm new to Linux so I have no idea what to do.

Can you post the output of this?
<code>wine --version</code>
In response to Flame Sage
In response to Crime fighter109
Do you still have the byond icon in your system tray?

If so, this sounds exactly like the behavior I've had when trying to use byond via Wine for a while now. I can't say I've put any effort into fixing it though, as I have a virtual machine with XP installed on it.
In response to Stupot
I've tried getting a virtual machine I don't remember which one but I have no idea how to use it. :(

Oh well I guess I may never be able to play BYOND.
In response to Crime fighter109
Using VirtualBox is really easy to set up. You will need a copy of Windows in order to install it in a VM though.
In response to Stupot
Oh okay unfortunately I can't afford windows xp.

But I do have a Windows XP re-installation disk is that the installation disk and can it install Windows xp?

Another thing is I have a whitebox computer so I was wondering if it would let me install it.
Okay so now for some reason every time I try to open anything with wine I get a Program Error that sais:

The program (Programhere).exe has encountered a serious problem and needs to close.We are sorry for the inconvenience.

Then below that it sais:

This can be caused by a problem in the program or a deficiency in Wine.You may want to check for tips about running this application.

If this problem is not present under Windows and has not been reported yet, you can report it at

I don't know why this is happening and it just started recently and it's happened with a bunch of programs.

Also when I try to install BYOND it sais:

Wine Program Crash
Internal errors - invalid parameters recieved.

In response to Crime fighter109
Have you tried reinstalling Wine or upgrading it to version 1.1.41?
In response to Majora2
When I type in sudo apt-get install wine it says:

for@for-desktop:~$ sudo apt-get install wine
[sudo] password for for:
Reading package lists... Done
Building dependency tree
Reading state information... Done
wine is already the newest version.
The following packages were automatically installed and are no longer required:
python-opengl python-psyco liby2-14 ttf-mgopen libglpng libwxgtk2.6-0
boswars-data python-numeric yiff-server libgnet2.0-0 python-pyvorbis
python-ogg libbulletml0d2 ttf-uralic libfltk1.1 chromium-bsu-data
libwxbase2.6-0 debtags liblua5.1-0 libboost-python1.34.1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

So I think I have the latest version.

I've been wanting to reinstall it but I don't know how to uninstall it.
In response to Crime fighter109
Looks like you have the latest version alright.
It's 1.1.42 now.

I've been wanting to reinstall it but I don't know how to uninstall it.

$ sudo aptitude reinstall wine

Using aptitude here because it has a reinstall function.
In response to 14mRh4X0r
Thanks for your help guys but unfortunately my computers hard drive failed so I guess I don't need to worry about it anymore lol.