ID:798263
 
Resolved
BYOND Version:494
Operating System:Windows XP Pro x64
Web Browser:Chrome 19.0.1084.52
Applies to:BYOND Pager
Status: Resolved (496)

This issue has been resolved.
Descriptive Problem Summary:
I can't load any game or download any demos, when I click the link, nothing happens. I have tried enabling EVERYTHING in chrome settings, but nothing works.

Numbered Steps to Reproduce Problem:
Attempt to load a BYOND file from the website.



Expected Results:
To load the game/demo.

Actual Results:
Nothing happening.

Does the problem occur:
Every time? Or how often? Yes.
In other games? Yes.
In other user accounts? Yes.
On other computers?I don't know.

When does the problem NOT occur?It didn't occur a few months ago, I have just gotten back on Byond, and installed the latest version.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

Workarounds:None.

I'm using Firefox 12.0 and BYOND 494.1133, Play Now links don't seem to work. They just link me to the download page even though I have BYOND installed.

I remember there used to be some kind of stub in my browser addons for BYOND but it doesn't seem to be there anymore. Reinstalling BYOND does not fix the problem.
In response to SuperAntx (#1)
Yup, still having this problem even with addons disabled.
In response to SuperAntx (#1)
Does the 493 installation work? I changed the installer and maybe that broke something.
In response to SuperAntx (#1)
Also, it'd be good to know if you are installing as an administrator or not. Although if you aren't, it should give a warning about browser plugins.
In response to SuperAntx (#1)
Wasn't installing as administrator.

I went and installed 493 and it fixed the problem. I then upgraded to 494 and it was still working. Tried uninstalling then reinstalling but I couldn't get it to mess up again. I'm pretty sure I've only installed 494 on this PC.

Also, the new installer is better for having the option to open my browser, but it still places a shortcut on my desktop and a folder in my start menu when I don't want it to!
I have the same issue since upgrading to 494.1135.

Everytime it just redirects me to "download BYOND".
Did you install BYOND as an administrator or as a regular user? I changed the installation setup and I believe I broke the case for non-admins who have write permissions (I am not quite sure how to simulate this though). I can upload a new test version to try shortly, but any details you can provide regarding the update (eg, whether it was a full-install and the permissions) would be useful.
Not as admin, As I am the admin on the PC didn't realise that it would make a difference.
Try installing it as an admin and let me know if that fixes the problem. I'll update the script to attempt an admin install in all cases and hopefully that will do the trick.
Downloaded 495.1136 ran as admin, rebooted and no change.
I recommend opening your task manager and monitoring what happens when you click a link. Does byond.exe open at all? If it does, that's a promising sign at least. As a followup, try opening the pager and using the File | Open Location to put in the URL. If the latter doesn't work, something is seriously wrong.
Clicking a link redirects to the download page when BYONDs
Pager is open.

Without the pager open nothing happened BYOND does not launch.

BYOND:// links do work via file > open location.
Can you verify that the 493 install works properly, but 495 does not?
Confirmed works with 493.
Sorry for the late reply.

That seems to have done the job, I also restarted the PC once again.

Thanks.
Huh, weird. OK, I'll make that the official install. BeignetLover, please try this version as well.
Still not working :( However, I found out that bookmarking the hub in the BYOND program works.
Does version 493 install properly for you, BeignetLover?
Page: 1 2