BYOND Version:453
Operating System:Windows XP Pro
Web Browser:Firefox 3.5.2
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:
On this computer, whenever i try to build host files to upload, it makes the zip file, which only ends up being 1kb. That zip file has nothing in it, and so cannot be used for hosting games.
This happens with EVERY game i am making on this specific computer.

I don't know if it's computer-specific. So until then, i'll use an external file zipper to 'package' the files from now on

Numbered Steps to Reproduce Problem:
1.) Compile host files
2.) Zip file fails to zip or something, i don't know. Could be computer specific

Expected Results:
Zip file to be larger than 1KB, and actually work

Actual Results:

Does the problem occur:
Every time? Or how often? Every time
In other games? Yes
In other user accounts? Not applicable
On other computers? Not sure

When does the problem NOT occur?
When i had my other computer, it worked fine. But that one since broke down

External file zipper
Seeing as this could be computer specific, i found a workaround.

I just zipped the rsc and .exe files myself and uploaded it to a file hosting website

works like a charm!
I use the same byond version and i'm not having issues with any of the 3 options under Build>>Package Files...

It could be computer specific or XP specic, as I am running Windows Vista.

Anyways, since as far as I know, byond doesn't use your other web browsers at all, and uses IE for everything like their embedded browser, it is likely not the cause either.

I see that the reason it probably fails is because something happens when byond zips it that windows and winrar don't do when it zips it up.
I've had zip libraries fail to work right during times of system instability. If you haven't tried it yet, I recommend rebooting your system to see if the problem resolves itself. If that doesn't do the trick, try re-installing BYOND.
I am using Windows XP Pro, Service Pack 3 (5.1 - 2600).
BYOND Version 453.1035
Firefox 3.5.2

I had no trouble with any of the 3 packaging options.
This has happened to me before, and there is a workaround.

Check the clean compile box when building the package.
Axerob wrote:
This has happened to me before, and there is a workaround.

Check the clean compile box when building the package.

Doesn't work; i've tried.