Fixed in 458
BYOND Version:457
Operating System:Windows XP Pro
Web Browser:Chrome
Status: Resolved (458)

This issue has been resolved.
Descriptive Problem Summary:
Objects(/obj) appear to randomly appear on all maps. This only appears to occur for objects placed on the map in DreamMaker.

Numbered Steps to Reproduce Problem:
Specific steps unknown, save that it appears to involve client.view somehow.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
Objects to only appear on the map they were placed on.

Actual Results:
Object appear on all maps, despite their coordinates not changing.

Does the problem occur:
Every time? Or how often? Every Time
In other games? None currently known
In other user accounts? Yes
On other computers? Yes (Both my computer and a linux-based host)

When does the problem NOT occur?
When there are no assignments to client.view

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
It occurs in versions back to: 456.1048 (It does NOT occur in 455.1047)

Removing all assignments to client.view appears to prevent the bug from occurring. All the assignments set client.view to the same value, and are the same as world.view
I'm sorry that this is so vague, but it's all I've been able to figure out so far.

My attempts at making a small demo that reproduces it so far have failed, however I have seen that removing all the (very redundant) settings of client.view from the game prevents it from happening.
There was a bug fix related to client.view in 456, so this was probably caused by that, but without a demo there is no way to reproduce or fix the issue. I'll mark this unverified till more information is available.
This demo reproduces the bug for me. self.aspx/.Public/BugTest^

Click one of the yellow tiles on the screen, and it will teleport you to an area that shows the bug, clicking one of the green objects will print out it's coordinates and those of your mob.
Bug fix: A fix to client.view in build 456 caused objects to sometimes persist even after changing z levels. (See issue 647)