Keywords: byond, connect, stuck, to, unable
Hi, my operating system is Windows 7, my main browser is Google Chrome and my antivirus is NOD32.

I'm unable to join any games, after a few months I didn't play at all on BYOND.
I don't have problems connecting to the pager, it says "Logged in as -Nick- [Public]" and I can chat with friends on it.

Problem is, that whenever I try entering a game, the light blue window appears saying "Launching etc", but thats about it; the game won't open up, even though dreamseeker is in the processes.

On my laptop (mounting Windows Vista) byond works with no problems and i can join every game, so I guess its not a problem of my network.

I tried solving the problem by uninstalling BYOND, deleting every byond folder on my computer and then reinstalling the latest version avaiable on the site, but didn't fix the problem.
Then, I've followed different guides over here like renaming the CFG folder and deleting cache, still not working.
I disabled windows firewall and every function nod32 has, and yet again it didn't fix anything at all.

If it can help, my current BYOND version is 496.1139.
Hi MajestyRoyale,

This is typically caused by a corrupted cache folder, however, if you have already deleted it (Check the folder itself to make sure it is actually deleted) then this points to a firewall issue.

Can you check your firewall settings again, and confirm that BYOND.exe, Dreamseeker.exe, and Dreamdaemon.exe are not being blocked or restricted?

Its also possible that you may have a firewall on your computer that you're not aware of. If you have a nvidea graphics card (or drivers) it may have came preinstalled with a firewall, and look at your process list to see if you can find any firewall programs you don't recognize running.

Good luck!
Actually, you were right.
My dad's account had installed Comodo Firewall and that was the issue.
I solved the problem by adding byond, dreamseeker and dreamdaemon to the exclusion list. Now everything works fine.

Thanks anyway, solved.