BYOND Version:459
Operating System:Windows 7 Ultimate 64-bit
Web Browser:Internet Explorer 8.0
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:When trying to run the game from dream maker it is slow.

Numbered Steps to Reproduce Problem:
1.Open something up, no matter how big or small the project.
2.Try and run the game, or use Ctrl+R to try and run it.

Now there is a big delay before it opens, the window even says stopped responding for about 5-10 sec before it opens.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:It to open up right away.

Actual Results:There is a big delay and the window is locked up while it opens.

Does the problem occur:
Every time? Or how often?Every Time
In other games?Yes, regardless of source, even in a blank project being run.
In other user accounts?Yes
On other computers?Yes

When does the problem NOT occur?When running the .dmb from going to it, instead of using dream maker to run it.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

I don't know.


Open up the folder the .dmb is in, and run it from there, and it will open just fine and fast.

It may either be related to having updated byond, using windows 7, or just my computer in general has something wrong with it.
Well One Reason for this problem is having too many files in your Project Directory.. I think during Compiling it goes through the files in the folder..
Actually, if you read numbered steps and all, will do the same on big or small projects, so, the small project had maybe 5 files, so this is not the issue.
Well, I do not have this problem on XP. I did however on Windows 7, but that's not BYOND's fault. Windows 7 takes up more resources than other OS's and slows down app's because of it. Photoshop, Visual C++ 2010, BYOND, Flash games, you name it and the cause is 7. (I do like 7 however don't get me wrong.)
Actually, I have a quad core computer running on windows 7 with 7 gigs of ram and such, and was running fine, and it opened just fine when running from the file directly and was only slow while using the run button from dream maker.

I don't think it was simply because windows 7 takes up more resources, but it was the beta RC version, maybe a bug in it leads it to screw up? However, I don't think I had the bug in previous versions of byond, maybe something I did while windows 7 was installed that made it to start erroring? who knows....or a bad windows 7 install maybe?

I do however have a good report for Windows Vista, with the latest version of byond, it does work correctly, but even a small change could have broken it on Windows 7. even if there was no byond change, likely a change of something on windows 7 produced the error from dream maker somehow.
I have the same issue, except that opening the .dmb directly from Windows Explorer is no faster.

I actually had time to open Task Manager, check that the Dream Seeker process had indeed started, stand around and consider what to do for a while, navigate to, click the link up top for the Bug tracker, find and click the link for this issue, and start typing before the options and messages window finally opened.
It happens to me exactly as IainPeregrine describes. I use Win7 (64-bit) and Chrome is my default browser (though I almost always have Firefox open, if that matters).
This happens to me on occasion.

It normally happens when I have another Dream Seeker window that's been open for hours.
Is your pager on when you do this?
Tom wrote:
Is your pager on when you do this?

The pager is on, but whether or not it still has an active connection to the hub is anyone's guess. Every now-and-again it's been known to stop receiving messages from the hub, which I assume means it's just lost it's connection (timeout?) somewhere along the line.

I generally find closing all active Dream Seeker windows and rejoining the games fixes the slow load times from Dream Maker.
If you are experiencing this issue when the pager is up, try closing the pager and seeing if that fixes it. My theory is that DS is getting delayed by communication with the pager (to log you in as your key instead of Guest, among other things). If we know that's the case, we can use that as a starting point.