Fixed in 461
BYOND Version:460
Operating System:Windows 7 Home Premium 64-bit
Web Browser:Internet Explorer 8.0
Status: Resolved (461)

This issue has been resolved.
Descriptive Problem Summary:Text mode does not like to correctly follow icon size. It is seen easily when switching from icon mode to text mode, the icon mode clearly takes up way more space, while the text mode is clearly smaller, if you have a hard time seeing it, you could add 64*64 icon size and 96*96 icon size, and it becomes drastically easier to see. While it does change when changing icon sizes, it doesn't get near as big as it should be getting.

Numbered Steps to Reproduce Problem:1.Make a blank project with map and icons, then switch between text mode and icon mode, and u can see text mode looks smaller than it should be, if u cant tell, bigger icon sizes seem to show it better.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:The map to be as big as icon mode, but just have text.

Actual Results:Text mode is smaller than the map is in iconed mode, can make text hard to read.

Does the problem occur:
Every time? Or how often?Every Time
In other games?Every Game
In other user accounts?Yes
On other computers?Yes

When does the problem NOT occur?When not using text mode.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
I dont know, but i think in the one isometric was it broke it.

There was an issue like this before, BYONDHelp?command=view_tracker_issue&tracker_issue=695

however, it is not the same, that one had a slight difference to its problem, but, i think that the problem started at the same time that issue appeared, so that is why i linked to it, so maybe from that one can remember what version broke it.

Workarounds:Dont use text mode.

Bug fix: Setting the map.icon-size parameter to a nonzero value when using a world.icon_size other than 32 caused incorrect scaling in text mode.
uhhh, actually, this was in a project that was using a default world.icon_size, and using even 32*32 map.icon_size will produce the error for me.