BYOND Version:462
Operating System:Windows Vista Home Premium 64-bit
Web Browser:Internet Explorer 8.0
Applies to:BYOND Pager
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:Sometimes I go to a website or something someone tells me to join a game or something, so I go click the link, and I do what I usually do, and nothing pops up.

Numbered Steps to Reproduce Problem:In my case.

1.Someone sent me a link to this page, so I go there and click the button to download it, do the usual vista stuff to allow it to open byond and such up and everything, and then, nothing comes up.

So now, I try again, nothing, so now, I close the pager, and bring it back up, click the link, and NOW it does work. So, simply, sometimes for some reason links don't like to work sometimes, and apparentally, since re-opening pager helps, maybe it's a pager problem.

I don't even know if the pager is involved in it opening or whatever, but, it's how I get it to work again.

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:It to open up right away no problem.

Actual Results:It takes till I restart the pager for it to start working again, there maybe other work-arounds though.

Does the problem occur:
Every time? Or how often?Sometimes it happens that it stops working, but it seems to stop working forever after it finally stops working, until the pager is re-opened.
In other games?NOT APPLICABLE. Seems to be all links to do stuff that it has happened on.
In other user accounts?Yes
On other computers?Yes, most people on BYOND, and even the guy who sent me this link has seen this issue.

When does the problem NOT occur?Don't know.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)
Don't know, I don't think it happened way back in 350 or so, I think it started once the new visual screen came up to show download progress, and the thing pops up saying play this game locally, or host, the blue splash screen or whatever.

Workarounds:Re-open the byond pager.

Did the pager have a red notification message every time you tried to download something? (I can't remember the message for the life of me unfortunately.)

Also, how long had the pager been running when this message started to appear?

If it did, then I can verify we're having the same issue, 'cept I'm on Windows XP.
The popups that come up is just like allowing it to open stuff, but, the pager was running at the time for days like it usually is, and links usually keep working even after a disconnect, so I don't know the cause of it.

And at the time, I don't think the thing is red as if I had recently got a message in my pager, and no popups that come up are red either.

The popups are just because I didn't check the always allow box, as those popups don't really annoy me.
Sorry, I was incredibly unclear, my bad. I didn't mean a pager notification, I meant a red error message from within the pager itself, where you would normally receive those notifications.
I haven't noticed this, but usually I am closing down the pager to reboot it when it happens, unless it specifically shows anything to tell u there is an available message when it happens, likely, I never looked.
Generally, this only happens to me when accompanied with the message "BYOND Central is not available" or something to that extent.

And it only every happens after times where bandwidth has been minimal for a mild to long period of time (downloading) or the pager has simply been running too long (a couple of days or so).

My guess is the pager loses connection to the hub, and it doesn't attempt to re-establish it. Or if it does, the attempt fails for unknown reasons.

Either way, I can verify that this happens to me a lot. So until the powers that be otherwise provide a reason for this behaviour, I'm marking this is a verified bug.
What exactly has been verified though? I've tried several times to parse the original bug report and can't make any sense of it. This needs to be massively clarified before I can look at it.
Lummox JR wrote:
What exactly has been verified though? I've tried several times to parse the original bug report and can't make any sense of it. This needs to be massively clarified before I can look at it.

To put it simply, the pager is timing out with connection to the hub, and it appears to be unable to re-establish it.

In my specific scenario, if I download say, 20MB, which should take roughly 30 - 40 minutes, taking all bandwidth away from other programs, it's natural to assume the pager will lose connectivity with the hub at some point. The problem here is, whenever I try to do something (other than send pages, which seem to work fine), I get bombarded with "BYOND Central is not available" messages when attempting to download anything off the hub.

Connections to games still work if done manually though the pager, but the website links are otherwise useless to me unless I close and reopen the pager, which I assumes simply tells the hub I'm back online. This also prevents me from receiving notifications from the website.

This kind of error also happens if the pager is left running for an extended period of time. I reset my computer, if I'm lucky, once every three days, but often diving deep into 7 - 12 days. I find myself having to restart my pager a great deal in order to make the website function properly with it.


Now is a prime example actually. My pager has been running for only 9 hours, in which there was a download I had going which finished about three hours ago. Since then, I haven't received a single notification from the hub, even though I should have had two. I'm also shown as offline on the website. Attempting to join anything from the site is giving me the exact message: "BYOND Central is not accessible."
Also, I believe his error is the splash screen not appearing during these events.

I can verify that can happen, but mostly that's sporadic for me.
I'm not sure Verified is the appropriate condition for this then, because there's no clear way to reproduce the issue. If the problem is known to happen but can't be reproduced with a consistent test case, Unverified is really the correct status. In this case I still don't have a numbered set of steps to follow or anything like that.