ID:906782
 
BYOND Version:497
Operating System:Windows 7 Pro 64-bit
Web Browser:Chrome 20.0.1132.57
Applies to:Dream Maker
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary: When ever try to map then compile/update map just crashes aswell as that Ctrl+K and Ctrl+U doesnot work.

Numbered Steps to Reproduce Problem:
1.) Open Map file
2.) Do some work on the game
3.) Compile /Update and DM crashes.
Code Snippet (if applicable) to Reproduce Problem:


Expected Results:Should Just compile

Actual Results:Crashes when click on compile

Does the problem occur:
Every time?

When does the problem NOT occur?

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit http://www.byond.com/download/build to download old versions for testing.)

Workarounds: use old versions

If you create a new project with just a bare-bones map, does it also crash when you compile? What about other, non-empty projects? Is there anything significant about the project(s) that is/are crashing?

Can you include the crash message and details in your report?
In response to DarkCampainger (#1)
nope i cant cause i dont know how to get detail but for the first question it crashes when i tried copying from older map i created it crashed.
There isn't enough information here to reproduce this issue, so I'll need to ask for some followup info and for you to edit your report. Here's some of the info I need:

1) Do you have any details on the crash, like which module crashed and at which offset? And which exact BYOND build are you running (major and minor version number)? This is important if you can get this.

2) What project were you compiling? Some big projects are more prone to issues than others, and in a couple of cases I've seen simple "out of memory" errors cause crashes. Does it happen in any other projects or just this one?

3) Which old versions, specifically, work? Does 496 compile the game? 495? How far back do you have to go to compile?

4) Does the crash only happen if the map is open?

I'm also willing to try this out myself to see if I can replicate the issue. You can send any source code to me in a .zip at LummoxJR@aol.com. Please include the ID of this thread and say in the subject line that this is regarding a bug report.
Lummox JR changed status to 'Unverified'