A Miner Adventure

by Forum_account
A Miner Adventure
Use a pick-ax and bombs to dig tunnels and build scaffolding to traverse the caves. Be careful, you'll never know what kind of danger you'll find!
i'm getting craaaaazy issues with the controls. i'll hold the right key and then press the jump key, and after 10 seconds of walking to the right my character will finally decide to jump (this is single player not-hosted, no lag). i'll tap the right key for half a second and then tap the left key for half a second, and my character will walk 5 paces to the right and then 25 paces to the left. all sorts of weird random things

it's impossible for me to go down the elevator in the tutorial level because my character always runs past the elevator while i'm not touching the keyboard at all, and then i'll lightly touch the left key to move one pace to the left and he goes dashing off to the left side of the screen eternally and can't be stopped
Have you had these problems in other sidescrollers? Can you open task manager and see how much CPU the game is using?

Clearly the game isn't coded to have a 10 second delay on jumping. My guess is that dreamseeker is burdened by drawing the screen and is missing keystrokes. There isn't much I can do to fix it (you can turn off lighting, that might help), but maybe it's a BYOND issue we can get fixed if we can figure out what's happening.
Forum_account wrote:
Have you had these problems in other sidescrollers?
nope, not in any. all the demos in your sidescroller library run perfectly (and are excellent!)

Can you open task manager and see how much CPU the game is using?
hovers at around 8-14%

you can turn off lighting, that might help
it seemed to help a little bit, but that may just be the randomness being on my side this time. after turning off lighting, i was eventually able to get on the elevator tile and go down, but it's still being very finnicky and doing things like moving me 10 tiles when i tap the key once, about 40% of the time. changing game settings to fast seemed to have no effect
If the Sidescroller demos run fine and the CPU usage is low, I'm not sure what would cause the problem here. You can double check that you have the latest version (it'll say "8.0.4" in the top-right of the title screen), but the low CPU usage has me stumped.

I'll look into this more later today. If you're experiencing this problem I'm sure that more people are too and they aren't saying anything.
I am confuss. Your game makes me dizzy.
Fun game. So far the only one on byond in the pass few months to keep my attention for over an hour.
A Miner Adventure? More like Underwater Exploration!

http://i44.photobucket.com/albums/f17/ZeiferB/ UnderWaterAdventure1.png

http://i44.photobucket.com/albums/f17/ZeiferB/ UnderWaterAdventure2.png

This setup was created by a labor of love by yours truly and Sarm.
Lol! I think it's possible for NPCs to drown, I should probably change that =)

And congrats on finding all of the hidden gems!
Forum_account wrote:
Lol! I think it's possible for NPCs to drown, I should probably change that =)

And congrats on finding all of the hidden gems!

Ya, there was no icon state for the npc dying. As soon as the water went above his head, he just disappeared.
Zaole wrote:
i'm getting craaaaazy issues with the controls. i'll hold the right key and then press the jump key, and after 10 seconds of walking to the right my character will finally decide to jump (this is single player not-hosted, no lag). i'll tap the right key for half a second and then tap the left key for half a second, and my character will walk 5 paces to the right and then 25 paces to the left. all sorts of weird random things

it's impossible for me to go down the elevator in the tutorial level because my character always runs past the elevator while i'm not touching the keyboard at all, and then i'll lightly touch the left key to move one pace to the left and he goes dashing off to the left side of the screen eternally and can't be stopped

Same type of things are happening to me. I'll hit right once, take my hands off the keyboard and the miner keeps going... can't stop him...
Sexy light system!
Why is it telling me I already have my Builder's Kit when I never even baught it? D:
NeonJ wrote:
Why is it telling me I already have my Builder's Kit when I never even baught it? D:

Whoops! Turns out it was checking the wrong variable (it was checking if you had the jump boots, then saying you had the builder's kit). This'll be fixed shortly.

Supertoby wrote:
Forum_account, Ryukusa is abusing his powers...

The majority of the game modes work fine when played solo. In career mode you don't have shared money, so there's not much of a benefit to playing with other people anyway. Anyone can download the game and host it, so if you don't like the people you're playing with, stop playing with them.
Also, the "Highest Roller" achievement seems to be broken. :<

EDIT: And the "Who" command!

EDIT2: And the options can be used by anyone, not just the host. D:

EDIT3: Also, when lighting effects are toggled / someone logs out, their light stays there.
Can you give me a screenshot showing that you have $15,000 and didn't get the medal. I tested the first three of those medals, but never got "Highest Roller" myself =)

Edit:
I just posted an update which fixes the who command and some lighting issues (I wasn't aware of the one you mentioned, but hopefully this'll fix it too). I know the display options can be used by anyone, but I'm not sure how to change it because the host isn't always in the game. I was thinking about making those options available only while you're in the lobby, but if performance starts to get bad while a game is running it's too late to change anything. I could make them only available to the person that's in charge of selecting the game mode. I'm open to ideas on this.
Yeah, only make it to the one in charge of the game modes. :3

http://img859.imageshack.us/img859/43/highestrollerfail.png Here ya go. Why didn't my comment post before?

Ok, there was a problem in the code that was causing it to not be awarded. I manually gave you the medal. If anyone else gets $15,000 in career mode but doesn't get the medal, post a screenshot and I'll give you the medal too. Or, maybe because $15,000 was too easy to get I'll take the medal away and raise it to $50,000 =)
"To create a single player game, click on "Single Player" at the main menu. Click on a mode of play to select it, then click the "Start Game" link."

I attempted to play this game for a good five to ten minutes, than I gave up. Anyone mind telling me what I'm doing wrong? I click single-player, than I get a menu consisting of the game modes, so I try and click and play one. Nothing pops up, no "Start Game" link, nothing. So my natural instinct is to spam click the game modes hoping for something to happen, which results in highlighting the text.

Flame Guardian, my guess is that you don't have javascript enabled. I can work on a non-JS menu, but some other features of the game rely on javascript. In the meantime you can look at this webpage and hopefully get it working: http://support.microsoft.com/gp/howtoscript

CyberHound, I'll award you the medal as soon as I can.
Page: 1 2 3 4 5 6 7