BYOND Version:498
Operating System:Windows 8 64-bit
Web Browser:Chrome 25.0.1364.97
Applies to:Dream Seeker
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
Attempt to join Hazordhu II from either the Replay button or the BYOND website or a direct link.

(Classic Pager)
(New Pager)
Stand alone launcher

Running Windows 8 64-bit

Dream Seeker will crash when attempting to load the game.

The only time I can get it to connect sucessfully is to restart my computer. Then I can play the game normally exactly ONE time, after I close out the game I can no longer get back into it without crashing Dream Seeker.

This only seems to happen on this one game.

I attempted to do a complete fresh reinstall of BYOND including wiping the MyDocuments folder.
This happens with the classic pager and the beta pager.
I think this has more to do with the Dream Seeker client itself.

Tom, is there any additional steps I can do to diagnose this problem? I'm out of leads.

Does the problem occur:
Every time? Or how often? Only occurs after the first time.
In other games? No
In other user accounts? Unknown
On other computers? Unknown

When does the problem NOT occur?
The first time after a reboot.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

This problem occurred even when I did a complete fresh reinstall of BYOND (uninstalled and wiped the BYOND folder in My Documents)

Reboot every time I want to play the game.
Have you tried disabling hardware rendering? Might be a video card related crash.
I haven't been able to try anything else due to the server currently being messed up.

But I was able to reconnect just fine (they have a corrupted RSC though.)

I think the problem relates to them automatically scaling the map based on the user's screen resolution. I haven't been able to verify this though, I'll ask Kaiochao again tomorrow to send me some test cases.
In response to Nadrew
Nadrew wrote:
Have you tried disabling hardware rendering? Might be a video card related crash.

This seems to be the issue.
For reference, I have an NVIDIA Optimus GPU currently running in Dedicated graphics mode. Nvidia's NVS 5400M GPU

The driver I currently have installed is:
NVIDIA 310.90

I assume this has nothing to do with the beta release, right? Since that didn't touch the graphics at all, I'd think you'd have the same problems in the public 498 as well. It would be good to know if this problem is new as of the DX9 build, which was the one that included the maptext (so about a year ago).
I am almost positive it was in the old version too.
I just figured I'd post it here because I also tested with the Beta pager.

I think it has more to do with Dream Seeker than the pager.

I honestly think it's a problem with the GPU driver, but if you have any specific versions of BYOND you'd like me to test with before I reinstall my driver just link me to them.

I think it may be possible that this is caused by the font not loading properly. Hazordhu's interface uses Tempus Sans ITC pretty much everywhere; if you look at the OP's first screenshot, you'll see blank buttons at the top-left and "OOC" at the bottom-left in the wrong font.

I've been experiencing a similar issue with maptext, actually. When trying to display maptext on login, DS crashes immediately, unless I delay the display of maptext until a few ticks after login. I don't think that one depends on the font.
Well shit if DS is crashing and you know the reason, you should let us know when it happens. Those are usually easy to catch. I'll try testing maptext with a bogus font. Is this only in hardware-mode?
In response to Tom
I've only ever used hardware mode, but turning it off has no effect (other than running slowly due to the large-ish screen size, but that's irrelevant).

Sorry I didn't mention it sooner.
I'm having the crashing problem as well. When I connect to the game and it crashes, the text becomes italicized and appears to be bold. If I rebuild the .rsc, it works.

To be clear, this has nothing to do with the beta, right? Not that it isn't a priority (fixing crashes is always at the top of the queue), but I want to keep the issues in the new software separate.
In response to Tom
I use the beta.
Yes, but does the problem happen in 498 as well? We need to be clear that the issue is not specific to the beta, because that would mean that we broke something (this is actually better since we would have an idea of where to look, but somewhat inexplicable since we haven't touched the client display code).

Actually I may have inadvertently fixed this in 1183 (to be released tonight). I found an issue with maptext not always initializing properly in some cases. It wasn't crashing for me, but it was causing the format to be screwed up (appearing in a different font, color, and/or style). However, the problem only was present in hardware-mode. So if using software-mode fixes it, that's probably it.
In response to Tom
I'm using hardware mode, and I do get some weird foreign font sometimes.