by Forum_account
This library gives you the basic movement system of a platformer. You can make an action/platform game in minutes!
BYOND Version:498
Operating System:Windows Vista Home Premium
Web Browser:Firefox 14.0.1
Applies to:Dream Seeker
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
At runtime on any demo, I get:
runtime error: bad index
proc name: slow down (/mob/proc/slow_down)
source file:,336
usr: null
src: Kaamos (/mob)
call stack:
Kaamos (/mob): slow down()
Kaamos (/mob): action(1)
Kaamos (/mob): movement(1)
: movement()
: movement loop()
: movement loop()
runtime error: bad index
proc name: action (/mob/proc/action)
source file:,241
usr: null
src: Kaamos (/mob)
call stack:
Kaamos (/mob): action(1)

over and over in an infinite loop.
I cannot move, but other things in the demo (AI, etc) continue to move around normally.

Numbered Steps to Reproduce Problem:
Run any demo

Expected Results:
Normal running, ability to move.
Actual Results:
INifnite looped error
Does the problem occur:
Every time? Or how often?
Yes, every time.

An issue that looks quite similar to this issue happens on Login(), I'm unsure if it is the same issue but try swapping lines 177 and 180 in the file of forum_account's keyboard library.

Sorry to bump such an old post, but I get this issue too.

When I swap lines 177 and 180 in the file, it no longer recognises keypresses at all.

Any ideas anyone?
Same here ... it seems if you reinstall forum_account's keyboard library and this lib and than this error happen
Well i fixed the problem this way



It seems seting icon size before movement speed create runtime error
Phat T, where exactly were you placing that line of code to achieve such results? I tried implementing your fix under world, hell, I even tabbed up the movement loop appropriately, but I still received the same errors.

Does anyone else have a fix for this runtime error? I was looking forward to using this library for a small project.
Problem solved. Deleting both the sidescroller library and the keyboard library followed by reinstalling them fixes the runtime error.
I'm getting the same error, but it only shows up on Dream Daemon and none of the mentioned fixes work :c