ID:1317673
 
(See the best response by A.T.H.K.)
I have purchased a VPS with vps.net and have a console using CentOS. How would I go about putting up a server? As I have no experience with linux..
You might want to look at the Linux Talk sub forum its near the bottom of this page.
Is CentOS linux? Because i tried using wget command to download byond to the server, but it says wget is not a command...
Best response
You'll need install wget first..

I believe it's yum -y install wget

Yes centos is Linux you stated that in your first post ;)
I installed byond, but when I try to verify I get this: [[email protected] ~]# DreamDaemon --version
-bash: /usr/local/bin/DreamDaemon: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
Are you on 64bit? You'll need the 32 bit libraries if so.
Yes, I am. Mind telling me how to retrieve 32 bit libraries?

EDIT: I have dug up a possible solution, only to change my problem. [[email protected] ~]# DreamDaemon --version
DreamDaemon: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


I performed the following:
yum install glibc.i686
yum install glibc-devel.i686

I'm on CentOS V 6.4 if it helps.
Try

yum install libstdc++.i686

As I believe they don't come with glibc
DreamDaemon: error while loading shared libraries: libbyond.so: cannot open shared object file: No such file or directory

It changed from libstdc++.so.6 to just plain old libbyond.so
now you need to do the source command
(you get it when you do make here or make install
)
I got my server up and running, but whenever I close out of putty, the dreamdaemon closes. Even with the ampersand at the end.

I'm using this:
DreamDaemon baystation12.dmb 6113 -trusted -logself &
Just create a script

#!/bin/sh #or #!bin/bash
DreamDaemon baystation12.dmb 6113 -trusted -logself &
Uh, I'm clueless as to how to create a script..
You should read up on how to use CentOS or choose a low entry Linux dist, Ubuntu is simple.

Why CentOS anyway? not like it matters all that much.

You'll want to create that in your home directory, use your favourite terminal editor, nano? vi?

Nano is great simple yum -y install nano

cd ~
nano start_dd.sh
Paste
#!/bin/sh #or #!bin/bash
DreamDaemon baystation12.dmb 6113 -trusted -logself &
Ctrl+X
Yes

Once closed you are back at your home directory.

ls to see files ls -la to see files permissions + more

chmod +x start_dd.sh

run the script

./start_dd.sh
I created the script and everything, but when i get to ./start_dd.sh i get this:
[[email protected] ~]# ./start_dd.sh
/bin/sh: #or #bin/bash: No such file or directory
Choose one of the two I provided don't copy and paste
Ohhh ok. I used #!/bin/sh
DreamDaemon baystation12.dmb 6113 -trusted -logself &

And it worked, but I need to point it to the correct directory, or else I get this: [[email protected] ~]# DreamDaemon: cannot open file baystation12.dmb.

How do I point it to: /root/APOC/baystation12.dmb
Modify the DD command..

DreamDaemon /root/APOC/baystation12.dmb 6113 -trusted -logself &
Works great! I can now close putty and server stays up :D thank you so much for being helpful and patient towards my noobness
In response to IDWMno
Thanks okay, it would still be best if you read on CentOS.
Page: 1 2