BYOND Version:503
Operating System:Windows 7 Home Premium
Web Browser:Chrome 32.0.1700.76
Applies to:Dream Daemon
Status: Unverified

Thus far we've been unable to verify or reproduce this bug. Or, it has been observed but it cannot be triggered with a reliable test case. You can help us out by editing your report or adding a comment with more information.
Descriptive Problem Summary:

File saving takes *way* more CPU using 504.1226 than it ever has before. A savefile that took 0.140 Total CPU seconds to save in 501.1217 takes almost 16 seconds to save now, and freezes the whole server in the process.

Note that I was hosting through the DD and had "threads off" toggled. I can't host a live game with threads enabled right now due to another reported bug.

Here are my results for the Total CPU time it took to save this file in various versions of BYOND:

501.1217: 0.140 seconds
504.1226 (threads off): 16.124 seconds

Edit: I previously had 503.1224 being different, but it's actually the same as 501.1217

Numbered Steps to Reproduce Problem:

To reproduce the problem simply create a datum with several large lists (thousands of entries) and try saving/loading it. The difference appears to be noticeable with any savefile, but using a large file will make the issue more visible.

Edit: I can't reproduce this when I host from the DD and join using a DS on the same machine. It may only trigger when a player connects to a remote server


For now I've downgraded back to BYOND 501.1217 on the live NEStalgia servers, which has alleviated the problem.
So to be clear, 503.1224 works fine but 504.1226 shows the issue, even with "threads off"? That is weird since thread enabling is the main difference between the builds, but we can take a look. Actually, 504.1225 with threads off should be absolutely identical to 503 so I'd be curious if that works (which would isolate the problem to the new code in 1226). Any reason you aren't hosting in 503 now? That should be stable and has access to more features and a few fixes. Obv if that isn't stable, we need to know.
Sorry, come to think of it I didn't test 503.1224 on the remote server. I'll try that now and let you know how it goes.
So 503.1224 works just fine when tested on the live NEStalgia servers - no sign of the bug.

In 504.1226 the bug happened every time, even after I restarted the VPS itself.
That's good.

If it's easy, could you try 504.1225 with threads off? This really should be identical to 503.1224 so would help isolate the problem to the new build.
Sure, I'll give that a try
504.1225 with threads off is working normally. Looks like the issue is isolated to 504.1226.
Ok, that's a good clue!
Lummox JR changed status to 'Unverified'
I am actually experiencing this as well. In the cpu profiler player saving was never very high, but now it is #1
experiencing this aswell in our new game only
I don't really think it's version specific- at least not in terms of version 504 being the only thing effected.

Reason being is I was running 501 up until a month ago. I updated to 503 right around the time that the credits update came out (then 503 was unstable)
I started experiencing the dream seeker crashes then, I also started having noticeable spikes in the game *pauses* during the game.(ironically enough it was after adding in an auto save system that saves every 5 mins)

This has since occurred, even after reverting back to 501, then updating to the stable 503 last week. (Just not as often.)

I ran the game on my computer- for about 8 hours, with no crashes. However as soon as the host runs a game- the game crashes within an hour or two.(# of players doesn't seem to matter, no run times, no profiling issues)

I'm thinking it may be a problem related to Dream Seeker/Dream Daemon- could it be possible that hosting games of conflicting versions would cause an issue like that? The host does have an older game being hosted- simultaneously along with hosting this new game made with the 500+ features.

Either way, the game has been suffering crashes for almost a week and a half now in beta testing sessions.
For those experiencing the savefile issue, please see if you can put together a test that shows the problem in action. I need to know if this happens with threading turned on and off, and at what old version it stops being an issue. When I tried to test this with Silk we found that I couldn't reproduce it and he stopped seeing it spontaneously, so I definitely need some more info to go on.
We could let you host the game that we're having troubles with so you can experience it first hand if you can