Not a bug
BYOND Version:504
Operating System:Windows 7 Home Basic 64-bit
Web Browser:Chrome 31.0.1650.63
Applies to:Dream Daemon
Status: Not a bug

This is not a bug. It may be an incorrect use of syntax or a limitation in the software. For further discussion on the matter, please consult the BYOND forums.
Descriptive Problem Summary:
When Dream Daemon is the parent, startup will work and create the child, or slave.

Now the slave is being used as a utility to manage other stuff, including updating the server with new files, but startup wont work for the child.

Numbered Steps to Reproduce Problem:

Create a world, have the world create a child via startup() and then have that child create a new child via startup()

Code Snippet (if applicable) to Reproduce Problem:

Expected Results:
Child worlds making more child worlds for infinite babies.
Actual Results:
No babies are made ;( they're all sterile.
Does the problem occur:
Every time? Or how often? Always
In other games? Unsure
In other user accounts? Of course
On other computers? Yep

When does the problem NOT occur?
I dont know, I would like to know though.
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

Before the 5.0 update it worked, from what I recall anyway.


use shell to manage daemons and use python for additional stuff but it seems a bit unnecessary.
There is good reason for this behavior, and I believe it is intended to be so. You can get around it by communicating with the "older brother" to create more babies.

Maybe there's even some params that might get this to work. -suidself might work
Lummox JR resolved issue (Not a bug)