BYOND Version:504
Operating System:Windows 7 Home Basic 64-bit
Web Browser:Firefox 27.0
Applies to:BYONDexe
Status: Open

Issue hasn't been assigned a status value.
Descriptive Problem Summary:
BYONDexe standalone executable does not launch if a previous version of the executable has already been run on the system.

Numbered Steps to Reproduce Problem:
1. Make a game and build a standalone executable
2. Run it
3. Update the game
4. Build a new standalone executable
5. try to run it

Code Snippet (if applicable) to Reproduce Problem:
Not applicable

Expected Results:
The game runs

Actual Results:
The game doesn't run

Does the problem occur:
Every time? Or how often?
Every Time
In other games?
Haven't tested
In other user accounts?
On other computers?

When does the problem NOT occur?
When the game is run for the very first time on a virgin machine.

Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

Delete the following folders from Documents/BYOND:

The standalone executable will now run properly.
Can you test this with v.506? There was an earlier issue that was causing this exact problem. Note that if the beta threading stuff is causing problems, you can disable that by setting -threads off through your hub.ini configuration.
Hmm, according to my notes that change I was thinking of went in for 504, but just to be safe, try it on 506. If you still have problems, we'll be sure to get this into testing ourselves.
Similar problems were also happening on yesterday's build of 506, but I ended up downgrading because it had a lot of framerate hiccups.

I'll try reproducing it again on 506, I guess.
Damn, please report the separate incident of the 506 issues in a Beta Bugs post when you get the chance.
Regarding the initial problem, I think I figured it out. You probably didn't bump the version, and because of that, it doesn't think it needs to re-extract the files (into mydocs/byond). It does it this way to be efficient, but we should probably look for other cues. I actually thought we were (things like crc of the exe), but it doesn't look like it in the code and I must have had some reason. [Edit] actually it should be properly accounting for changes to the exe itself even if you don't bump the version. So this may be a red-herring.

Anyway, try to bump the version with each new release and maybe that will fix it (although in light of my last edit, I doubt it now). In the meantime, I'll see about improving this.

Also, please post any beta issues you have whilst testing this or anything else.

[Edit] -- that said, I'm not sure why this would cause it not to run. I could see it not updating and just running the old build, but it's weird that it is failing entirely. I guess we need to test more.
I found a bug with the current byondexe that may have caused a problem (although to be honest, I'm skeptical). It is a tiny patch so I just reuploaded it. Can you try it

and see if it solves your initial problem?
I believe that solved it?
I cannot reproduce the problem on my machine or anyone else's.

I am still getting severe framerate problems with version 506, but that's kind of unrelated.
Ok, good to know. There was a pretty significant bug related to this so that might explain it.

Please test as much as you can in 506 and post a bug report. You can disable the threading for the exe version if you want to use 506.
How do I go about turning off threading for BYONDexe?
I am actually not certain but I have forwarded the question onto Lummox JR. If we can't do it currently, we can provide a field in the hub.ini to pass startup server arguments.
There's currently no param to turn off threading, but I can add that.

Doing this as command-line arguments might be iffy (and potentially unsafe, as we don't want to be able to force trusted mode), but adding some simple params called Threads and MapThreads (to keep with the naming convention used in other hub.ini options) is easily doable.
We'll hash out an appropriate notation. In the meantime, you can use this new build with 504. Just download the 504 byondexe and replace the "mydream.exe" with the version from this latest 506. It's an independent program that has the fix you need (in a nutshell, this is the exe that is renamed to your game, and it is responsible for extracting and launching the actual standalone connected to your dmb).
We decided to go with CommandLine as the new option for hub.ini. It will let you tack on additional command line options like "-threads off" so that you can disable threading:

CommandLine = -threads off

This is with BYONDexe version 504, but with 506's mydream.exe
I think the problem for him is unrelated to the version stuff from the OP of this thread, but I don't know how to reproduce it.

If it helps, here's what I used for

Could you find out what os he is running? Or he could register and post a bug thread here so we could converse directly.

One thing he might try is installing BYOND and seeing if that changes anything. It shouldn't and obv if it does that's a big flaw, but I'd like the datapoint. I will test on some clean platforms today.
I've tested it myself on Windows 8 and Windows 7 Home Premium, and it runs fine on my machines. I haven't tried it on anything older.

I've tried it after uninstalling BYOND, and I've tested it on my laptop, which has never had BYOND installed. It ran on both.

He says he's running it on Windows 7 64bit.
Did the game properly extract to his mydocs/byond folder? If he runs the renegade.exe in that folder, does it work? Is there anything unusual about that folder, eg is it on a network drive? That is a bug that is patched in 506 so you might get him a build with that version to test at least (we'll get the commandline setting out today).
It would probably be easiest to chat with this guy directly. If he is willing, see if he can give me his aim/msn/whatever and I will try to see what's up.