Space Station 13

by Exadv1
Space Station 13
Stay alive inside Space Station 13
BYOND Version:506
Operating System:Windows 8 64-bit
Web Browser:Internet Explorer 10.0
Applies to:Dream Maker
Status: Open

Issue hasn't been assigned a status value.
For some odd reason when ever I edit My servers map for SS13 if I edit some areas Like Research When I get on the game It will skip tiles It appears to do this at random because I have Remade the entry area and it doesn't do it I have no clue as to Why or How Map editing is causing Tile skip If anyone has Info or the same problem I can use the Help thanks:

1. Edit a area of the map 2.update 3.compile 4.Start server 5.Join server:

Code Snippet (if applicable) to Reproduce Problem:

game runs with new areas:

new areas are added but The players skip tiles instead of using the animations they just jump from tile to tile:

Does the problem occur:
only when I edit certain areas?
I have not tried
I have not tried

When does the problem NOT occur?
when I edit other areas
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)


From the Baystation 12 wiki:

So you compiled the map and suddenly whenever you move you no longer get the animation of moving but just 'appear' on the next tile?
So a while back step_x and step_y were introduced to allow pixel based movement. SS13 does not utilize this. Step_x and step_y are variables that each atom has. The way they work is that as soon as you set any object on the map to use one of these variables, the game interprets that you overrode all default movement code and wrote your own - but you didn't (The code that makes the animation from tile to tile).
To fix this problem you need to close dream maker (save the project first, obviously). Open your map (.dmm) file in a text editor, such as notepad or notepad++. Search (ctrl+f) through the file for step_x and step_y and remove any reference to it. Once no more step_x or step_y -es are found in the file, save it and open it in dream maker once again. Compile the code and movement should work fine once more. Go to the development IRC if you need more help.
Thanks I never would have guessed that the atoms I was placing where overriding the default code