BYOND Version:507
Operating System:Windows 7 Pro 64-bit
Web Browser:Firefox 33.0
Applies to:Webclient
Status: Resolved

This issue has been resolved.
Descriptive Problem Summary:
I have attempted to try a web client for my game Soul Elysium and it seems in Internet Explorer/Firefox/Chrome the client downloads then simply goes blank white. I also wish to note that it did boot me from Dream Seeker when attempting to connect via web client saying another connection has been made, so it is connecting somewhat.
Numbered Steps to Reproduce Problem:
1) Host via 507 using DreamDaemon of course with the feature enabled.
2) Attempt to connect via web client through the game hub page.
Code Snippet (if applicable) to Reproduce Problem:

Expected Results:

Actual Results:

Does the problem occur:
Every time? Or how often? Every time.
In other games? Not sure what the circumstances are, but it seems to work in my smaller less resource heavy project.
In other user accounts? Yes.
On other computers? N/A

When does the problem NOT occur?
It seems one of my lower resource heavy projects which is a 1.3 MB download versus Soul Elysium which is about 18 MB loads up perfectly on the web client when hosted through the exact same means as Soul Elysium, same server, even works on all the mentioned browsers.
Did the problem NOT occur in any earlier versions? If so, what was the last version that worked? (Visit to download old versions for testing.)

I'm assuming it has something to do with how extensive my game is on interface use and interface customization, not sure if anything else would effect the visual.
Harmony Online's new client is interface heavy as well. I generally get an unresponsive script dialogue prompt. When viewing the console it ended up stopping on converting the interface.

I just left it be assuming I should just manually create the interface in javascript.

With that said, check the console when this happens and let us know what it says. It might give the developers a better idea of what's going on.
Oh I've already worked with Lummox on the matter but thanks for the reply!
Lummox JR resolved issue