(See the best response by FKI.)

Problem description:
how can i make this icon overlay that is 96x64 so i can see full icon

Best response
Sounds like you're using the TILED_ICON_MAP setting, which is deprecated. Said setting forces you to have to add icons that are larger than your default world.icon_size in pieces. An example of putting together a 64x64 icon:

icon = 'ulqres.dmi'

tl // top left
icon_state = "0,1"
tr // top right
icon_state = "1,1"
bl // bottom left
icon_state = "0,0"
br // bottom right
icon_state = "1,0"

An alternative would be to update your world.map_format and use TOPDOWN_MAP, in which case the method in your post would work and you wouldn't need to add it in pieces. Note that changing to this setting is going to seemingly mess up many of the icons on your map; all you have to do is replace them (as in delete them and add it to the map again).
its just 1 icon btw