I tried hosting a game with my new router, and as expected I needed to forward a port.

I followed the directions here:
and here: Netgear/WGR614/default.htm

I tried again to host the game, it shows up on the website but does not allow players to join the game.
Any reason that after I have a static IP and set up a range of ports that I can't properly host a game?
Did you use the checker tool to see if the port is open?

Go to command, type in ipconfig, and check that the IPV4 address is the same one the port was forwarded on.

Also, setting a static ip like that only sets it for the computer, you will want to make a reservation on the router to make sure it doesnt get given to someone else.

If you need help add my msn : [email protected]
In response to Pirion
You don't need a static-IP. I don't and I can host.
In response to Pirion
I don't use msn, I e-mailed you but you didn't return it.
I still can't port forward even though its set up on the router.
Bump. I still cannot host with ports 1500-3000 forwarded or at least it says they are in my routers editor. Read the first message to see what I've already done.