Not a bug
BYOND Version:507.1283
Operating System:Windows 8 Pro 64-bit
Web Browser:Chrome 42.0.2311.135
Applies to:Website
Status: Not a bug

This is not a bug. It may be an incorrect use of syntax or a limitation in the software. For further discussion on the matter, please consult the BYOND forums.
Descriptive Problem Summary:
There's no longer a "Play Now" button next to games.. the only way to play them is if they have the webclient enabled. Well, you can also copy the link displayed, but that's... eh.

Use the pager.
This sounds like a browser issue on your end as every game I see, at this moment, has a Play Now button if the game has host files or is being hosted.

Can you elaborate more? The Play Now button doesn't exist at all for any games or is there specific games you are trying?

Have you cleaned your cookies on your internet browser, closed the browser, opened it back up and revisited the hub page again and still no Play Now button?
This is all I see for any game that doesn't have webclient enabled. Image and video hosting by TinyPic
Looks to me like the system thinks you're not using Windows for whatever reason. Have you tried it in another browser like Firefox?
I just tried it with IE and it's the same issue. I don't have any other browser installed, and I don't really feel like installing a new one.. <.<
Very strange indeed, I'm using the same version of Windows without issue. It's definitely an issue with OS recognition since it's giving you the message that appears when non-Windows clients access those pages. You can follow the directions it gives to play the game in the meantime, but I'd imagine someone with a little more insight into how the script is detecting the OS (Lummox) will have to weigh in for a more reasonable solution.
FishMan, can you open up developer tools and look at the network requests for me? I'd like to see what your user-agent string looks like. It seems that it's not being interpreted correctly, so it's probably something our script hasn't seen.
In response to Lummox JR
I'd love to be of help, but I quite frankly have no idea where the "user-agent" string is located at. The "find" feature doesn't seem to work on actual code. If you could tell me which file it is located under, then I can play a little bit of hide and seek with it (:
You need to open up the developer tools in your browser, and go to the area where it can view network traffic. When you go to a hub entry, open up that request to look at the details. It should show you the user-agent string your browser sent, along with a bunch of other things. There also appear to be lots of sites on Google that will show you your user-agent.
You can simply visit to get the data if you don't want to dig through the data.
Image and video hosting by TinyPic
You're going to have to post the whole thing, there should be more, including your Gecko version and Windows version.

If there's nothing else to it, the issue is the user agent for some reason omitting the information BYOND needs to know you're using Windows.
In response to FishMan123
If that's your entire user-agent string, no wonder! Find out what plugin/extension you're using that's altering that, because it should at least be including your OS.
That's basically it. I am using this website: and the only other things being said are rather irrelevant.

Image and video hosting by TinyPic
There's definitely something altering your user-agent to show less data, for some reason. It's either a plugin or a system setting (since it happens in IE too, I have to wonder).
In response to FishMan123
Nadrew's right; something is modifying your user-agent. If it's in multiple browsers the main culprits would be a system-wide issue like aggressive antivirus, your ISP, or a proxy if you happen to be using one.
Yeah, I was using a proxy. I took it off and here's what I got:

EDIT: The issue has seized to exist. Sorry for all of the trouble.
Nadrew resolved issue (Not a bug)
Glad it worked out for you. If you configure the proxy to leave your user-agent intact or at least leave the OS alone, it should be fine.