(See the best response by AERProductions.)
I'm not able to login into BYOND Pager. When I try to open BYOND, the pager loads but the login prompt doesn't. I've tried restarting my computer, but that didn't work. I've tried uninstalling BYOND and downloading it again, that didn't work.

If I go to Task Manager, right click BYOND and hit maximize, the BYOND Pager shows up. However, the login in prompt doesn't.

The BYOND Pager won't allow me to click "login" either. The same effect it has when the prompt is up and you're trying to click past it happens; nothing. I've tried finding the hotkey for login, like ctrl+whateverletter, but that doesn't work either. The hotkey for opening DreamDaemon work though.

I am a host for a game and I need to get this resolved as soon as possible to I bring the server back up and play it myself, so please help.
Best response
What version are you running? Have you updated yet?
Also, I notice AVG running in your task bar -- go ahead and delete that from your system. Your second screenshot is black and shows nothing, btw.

After removing AVG, try uninstalling byond and installing the beta. Also make sure that no Byond.exe is running in your taskbar. Which OS are you running, as well? Win7, 8?
When did this start happening?

Like AER, I highly recommend getting rid of AVG. It hasn't been a trustworthy piece of software for many years now, and I've seen it actively interfere with BYOND on some people's systems.