Ok byond was working fine just a week ago and this problem started even before I updated. I even uninstalled and reinstalled it and still nothing.

The launcher opens up when I hit to play a game and it'll load for awhile then the launcher will dissapear/close out but the game does not pop up. Help??
We'll need way more information: OS, what games you tried to play, what messages you saw, exact steps you took, etc.

In the meantime, one simple thing I recommend is making sure your Flash for Internet Explorer (even if you normally use a different browser; IE's Flash is different) is up to date.
I am using Windows 8.1, and I am trying to play this NarutoFinalFight this is all I ever see after I press play no messages appear. The launcher just closes after a short while and nothin happends
Do other games work for you? Have you tried updating Flash?
I have not, and I tried another game and it works
There might be an issue with that particular game, then. Maybe it's not actually running and the hub is reporting a ghost.