When I follow the steps, I type make, then i followed the steps and typed
Make Install, all files said permission denied.

NOTE: I'm new to ubuntu
you'll need sudo to install byond

sudo make install
I did that. Started off by going into the terminal typing cd ~/byond sudo make install then it finished downloading, it then said to find out more about the software type 'man DreamDaemon' I did so and i still get the same result
Byond is now at least installed.

I don't know why you don't have permission to view the man file

Is this some kind of shared hosting?

edit:not != now
I also tried switching over to using wine, i installed the Windows CLL's(mfc42, vcrun6 and wsh56) and IE7 and IE8. But its stuck on the getting game information from the byond hub, and i can use all shortcuts fine. Ctrl+L, O, etc. But i tried connecting to SS13 and i cant. It stays on the your game will begin shortly screen now.
On wine, when i started up byond, the first time was the top pic, the second time after i restarted it it looked like the pic on the bottom
Okay so, on Wine. I can connect to games perfectly fine. With one exception. Dialogue Boxes are black. I can connect to any game. Dragon Universe. SS13. Naruto Next Generation. Shinobi.
Are you trying to run Dream Daemon or the client?
the client.
I also had the man files have incorrect permissions for some reason, the following should fix it:

sudo chmod a+r /user/local/byond/man/man6/*
In response to PJB3005
sudo chmod a+r /user/local/byond/man/man6/*

This right here should be added to the makefile. Don't know why it's not there by default.